How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HVAC Guru Your Own Question
HVAC Guru
HVAC Guru, HVAC TECH
Category: HVAC
Satisfied Customers: 13986
Experience:  15yrs in the HVAC industry with certificates and degrees.
21107370
Type Your HVAC Question Here...
HVAC Guru is online now
A new question is answered every 9 seconds

We have a trane xe90 it fires up, burners comes on runs a

Customer Question

We have a trane xe90 it fires up, burners comes on runs a few minutes and then starts to cycle on and off. Does this a few times then nothing. Shut the system off completely then turn on again, works 3-5 minutes and starts cycling again
Submitted: 7 months ago.
Category: HVAC
Expert:  HVAC Guru replied 7 months ago.
Hello,That is typically a dirty flame sensor rod. You need to remove the flame sensor rod by the burner and clean the rod off with emery or fine sand paper then try it again. That often will completely solve the issue for that problem. If not let me know.All I ask is please use the star rating link at the top of your page before leaving to credit me through the site.
Expert:  BillyHvac replied 7 months ago.
Hello, If it runs a "few minutes" it is likely related to blower, filter or something else causing overheat. A sensor is usually the culprit if it 2-3 seconds cycling
Expert:  HVAC Guru replied 7 months ago.
Just get back to me HVAC GURU when checking it out first and then we can go from there. HVAC GURU
Expert:  HVAC Guru replied 7 months ago.
Hi there,I was just touching base with you because I have not heard back from you and the question is still open and unrated, if there is something else I can help you with follow up questions are free and can still be handled even after you rate the answer or did you just forget to rate the answer?