How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Phil Your Own Question
Phil
Phil, Mechanical Engineer
Category: HVAC
Satisfied Customers: 5648
Experience:  Retired HVAC/ Electrical & Boiler contractor. Industrial
23932409
Type Your HVAC Question Here...
Phil is online now
A new question is answered every 9 seconds

I have a Frigidaire dryer, model number LEQ1452KSO. I have

Customer Question

I have a Frigidaire dryer, model number LEQ1452KSO. I have 240 volts at the terminal block and all sensors have continuity as well as the heat element. I replaced the circuit board and had the motor checked outside of the chassis. Also the door switch is ok.the problem, nothing comes on. I have 120 volts at T2 but only 47 volts at T1, also chassis ground is good. Nothing happening at the control board, no lights either. Please help!
Submitted: 7 months ago.
Category: HVAC
Expert:  HVAC Guru replied 7 months ago.
Hello and thanks for using this service, if you have been waiting do not worry or get upset. I am Appliance Guru an extremely experienced tech on the site and I try to get to as many customers as I can. I just picked up your question now. NOTE it takes time for me to type research and add links so please wait for me to respond back I can only do this so fast. Secondly I am not paid anything until you rate my service good using the STAR RATING LINK at the top of your page, the money is paid to the site not me directly. So what exactly is not working?
Customer: replied 7 months ago.
Nothing is working, not even the low wattage appliance light inside the dryer. I am an appliance tech as well. I have 240 volts at the connection terminal and a good ground. What is strange is, on T1 my meter is reading 47 volts from the terminal block through out alloud the contact sensor, control thermistor, thermal limiter, door switch, and drum light. T2 has 120 volts and runs to start and run on the motor, then to the 4500 watt heater coil, then to the high limit thermostat, to the heater relay inside the control panel, which is new. Seems odd to me that from T2 to M2 at the motor wire harness my meter reads 240 volts on a single black line. I have continuity at all the sensors and switches on T1 leading to the control circuit board, as I said though, @ 47volts. Do you have the wiring diagram for this dryer? Have any ideas? Also the control thermistor does ohm out at 50 ohms at room temperature. No response from the control board, no lights come on. I have an instruction sheet explaining what buttons to hold down for 6 seconds then two more buttons to hold for 4 seconds to obtain trouble codes, but as I've said, no lights or the 2 dails on the control panel work. HELP!!! Thanks...