How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Phil Your Own Question
Phil
Phil, Mechanical Engineer
Category: HVAC
Satisfied Customers: 5648
Experience:  Retired HVAC/ Electrical & Boiler contractor. Industrial
23932409
Type Your HVAC Question Here...
Phil is online now
A new question is answered every 9 seconds

I have a Heat & Glo ...When activate it the Gas works but it

Customer Question

Customer: My name is Ernie! I have a Heat & Glo ...When activate it the Gas works but it is not igniting
JA: Thanks. Can you give me any more details about your issue?
Customer: I don't here the igniter clicking when activated. I checked it out and I believe it is flashing a code on the LED.. It flashes twice every 4 seconds
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to HVAC Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: yes I will
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 11 months ago.
Category: HVAC
Expert:  airheatman replied 11 months ago.

What is model on unit?

Customer: replied 11 months ago.
This is what is written Z21.591996•CGA2.21-M96
Expert:  airheatman replied 11 months ago.

That is a certification number. Look for a number like MDV31 or similar so I cam locate a manual

Customer: replied 11 months ago.
SL-75OTR-DSI
Expert:  airheatman replied 11 months ago.

!> Have you cleaned the spark igniter?

2.Do you see a flash code chart on the ignition module to tell us what the 2 blinks indicates?

Customer: replied 11 months ago.
I cleaned it and no chart
Expert:  airheatman replied 11 months ago.

I could not locate a chart either.I suspect the module to be the issue.