How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Phil Your Own Question
Phil
Phil, Mechanical Engineer
Category: HVAC
Satisfied Customers: 6022
Experience:  Retired HVAC/ Electrical & Boiler contractor. Industrial
23932409
Type Your HVAC Question Here...
Phil is online now
A new question is answered every 9 seconds

I have a Ruud achiever 90 plus that is just blowing cold

Customer Question

Customer: I have a Ruud achiever 90 plus that is just blowing cold air. I cleaned the fame sensor and ignitor, but still not operating
JA: Thanks. Can you give me any more details about your issue?
Customer: I turned furnace on and off and it doesn't ignite. I am assuming that you should be able to see a flame in the little window.
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to HVAC Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: sure if it fixes it, it will save me money, I hope
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: HVAC
Expert:  airheatman replied 1 year ago.

Are you getting an error code?

Customer: replied 1 year ago.
I don't know. When I take the bottom cover off, the furnace stops (fan blower, I think). There is no code on the board.
Expert:  airheatman replied 1 year ago.

Hold door button in and call for heat,watch and see if we get an error code by blinking light on board

Customer: replied 1 year ago.
It looks like its working ok now. I unplugged and plugged back in a few connectors. Maybe it was just a loose connector. I don't know. Thanks for your help and time.
Expert:  airheatman replied 1 year ago.

Just let me know if it gives you ant more problems.