How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Phil Your Own Question
Phil
Phil, Mechanical Engineer
Category: HVAC
Satisfied Customers: 7917
Experience:  Retired HVAC/ Electrical & Boiler contractor. Industrial
23932409
Type Your HVAC Question Here...
Phil is online now
A new question is answered every 9 seconds

I have a gas fired Rheem pool heater and it stopped heating

Customer Question

I have a gas fired Rheem pool heater and it stopped heating with a FFL code. What do I need to do to fix it so that it continues heating?
Submitted: 1 year ago.
Category: HVAC
Expert:  Phil replied 1 year ago.

Hello,

It looks like a water flow issue so far, make sure the line filters and strainers are clean.

Please attach a well focused, close up photo of the wiring diagram glued inside the service panel, the picture needs to be taken from straight on, in very good light.

You can use the paper clip- icon at the right end of the tool bar at the top of this dialog box to attach it here.

If there is no paper clip-icon, look for the '+attach files' link at left of your send button.

I can mark it up with trouble shooting instructions.

Customer: replied 1 year ago.
Thanks Phil, I attached 7 photos. The first 5 were of the inside of the service panel and the last 2 were of wiring diagrams in the owners manual. Also, I just pulled the last 5 fault codes off the unit and they were PRS (Water Pressure Switch Open) and FFL(flame sensing when pilot and gas valves are closed. I backwashed and cleaned the filter which did not help. The pressure is back to normal. Thanks
Expert:  Phil replied 1 year ago.

Thanks, ***** ***** of symptoms points to a bad printed circuit board. (80% chance, but not 100% so far.)

we can do a heat stress test that will help narrow that gap.

Use a hair drier to slowly and gently warm the card to 120F(warm to the touch but not hot and not over140F)... if you get any change in behavior that means the card is bad...

A micro crack has opened in the printed circuit at a solder joint, or inside its CPU in that case .... or a short circuit has developed as the card expanded when you heated it.

Constant expansion and contraction as these electronics heat and during their duty cycles over the years is what wears these cards out.

It is also a good idea to replug all of the connections in the unit,that burnishes any oxidized terminal connections and will sometimes solve the problem, especially at the printed circuit card and in any sensor molex connectors. Do that with the power off to the unit of course.

We can go from there.

Customer: replied 1 year ago.
Thanks Phil, we neglected to clean the filter the first time, and after we did the heater worked fine. Problem solved.
Thanks
Expert:  Phil replied 1 year ago.

Good work!

If you appreciate my input so far, rate my work positively... we can go from there. The company only pays me if you rate positively,lacking that I can spend days with a customer at my own expense,without any compensation. Rating does not increase your charges or close the question and it allows you unlimited follow up.