How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Phil Your Own Question
Phil
Phil, Mechanical Engineer
Category: HVAC
Satisfied Customers: 5648
Experience:  Retired HVAC/ Electrical & Boiler contractor. Industrial
23932409
Type Your HVAC Question Here...
Phil is online now
A new question is answered every 9 seconds

My thermostat appears to work correctly, then reboots

Customer Question

My thermostat appears to work correctly, then reboots occasionally without warning. The interval varies, but it is typically about 7.5 min between restarts. When this happens, it loses the date and time and take several minutes to reset. By the time the AC kicks on again, it only runs for a few minutes before another reboot. Any idea what could cause this? The thermostat is Lennox iComfort 103445-04, with software version 02.13.0240.
Submitted: 1 year ago.
Category: HVAC
Expert:  Phil replied 1 year ago.

Hello.

That is an entirely unheard of problem...and always points to a printed circuit board failure ... either in the thermostat or the furnace. It is also possible that it is bad wire connection.

Field repair is generally not cost effectively possible.

Tell me about how old the thermostat is, and how old the furnace is please, we can go from there.

Please attach a well focused, close up photo of the wiring diagram glued inside the service panel, the picture needs to be taken from straight on, in very good light.

You can use the paper clip- icon at the right end of the tool bar at the top of this dialog box to attach it here. ,Include a picture of the thermostat wire connections to the printed circuit board in the same area.

If there is no paper clip-icon, look for the '+attach files' link at left of your send button.

I can mark it up with trouble shooting instructions.