How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask BillyHvac Your Own Question
BillyHvac
BillyHvac, Journeyman HVAC Tech
Category: HVAC
Satisfied Customers: 22098
Experience:  Endorsed for unlimited heating, cooling, oil burners, boilers, refrigeration, hydronics
12672042
Type Your HVAC Question Here...
BillyHvac is online now
A new question is answered every 9 seconds

Gday mate, i have a vulcan ducted nat gas unit, new in 99, been terrific. woke up this am

Customer Question

Gday mate,
i have a vulcan ducted nat gas unit, new in 99, been terrific. woke up this am to cold house, not starting.
I removed the cover over the pcb and read the fault code as a 7, which key tells me is an Ignition failure. the blower fan is running fine, heater cycles after abourt 15 seconds of blower un and pressure switch engages, next the HSI red led turns on and after about 10 seconds the gas solenoid engages as per normal operation and you would think it was about to ignite and burn as normal. However at this point all the LEDs turn off, solenoid shut down and heater throws Igmtion failure fault code.
Can you tell me where on PCB I should check ign output and if its ok where I find the igniter to check it out please
Submitted: 1 year ago.
Category: HVAC
Expert:  BillyHvac replied 1 year ago.
Hello,
follow the gas pipe to the burner...the ignitor will be at the first point of gas coming out. We need to know if the ignitor glows or is bad.
use reply
Customer: replied 1 year ago.
Hi Billy,
very cold few days so I continued to toil away on Sunday . Found Igniter myself and it failed to glow, but when I removed it and supplied separate 24V supply (as labelled) it glowed fine .So removed gas supply and delivery on both sides of solenoid which when cycled showed me no Gas was coming through, hence Ignition failure because nothing to light so auto shutdown after about 3 seconds. So I removed Solenoid coils etc and found it to be faulty I reckon. So I've ordered a new solenoid but will take 3 days to come so still very Cold!! Will keep you in the loop.
Expert:  BillyHvac replied 1 year ago.
well done.
Not many are as savvy at troubleshooting like that...
just let me know what happens

Related HVAC Questions