How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mark Henley Your Own Question
Mark Henley
Mark Henley, Journeyman Technician
Category: HVAC
Satisfied Customers: 3217
Experience:  UA Journeyman Pipefitter , HVAC, Refrigeration, DDC controls. 26 years.Commercial & residential
Type Your HVAC Question Here...
Mark Henley is online now
A new question is answered every 9 seconds

I have a new heil ps80 furnace that is flashing code 3 - pressure

This answer was rated:

I have a new heil ps80 furnace that is flashing code 3 - pressure switch open when should be closed on single stage models. Low pressure switch open when should be closed on 2 stage/vs models. The model number for my furnace is N8MPN075B12B1



The code means that the vent motor is running but there is no pressure differential being sensed by the pressure switch. The pressure switch is a device like the one in the photo,


View Full Image



If you remove the 1/4" hoses on this and clean out the barbed fittings that the hose (s) attach to you may get it to work, this device is there to ensure that you exhaust vent is clear before firing the furnace.


Is the vent motor running ?


Let me know,



Mark Henley and other HVAC Specialists are ready to help you
Customer: replied 7 years ago.
The pressure switch is fine, but I beleive that the motor is froze up, as its not able to be turned by hand. I thank you very much for your quick responce and help. Thank you very much, WIlliam



That makes sense , unfortunately its not the repair we wanted.





Customer: replied 7 years ago.
ok, got the fan motor freed up. Only thing I can think of is that it drew moisture and froze up from that, but it is running now. The hose that comes off the fan house is blowing air, but my pressure switch, from what I can determine, uses vacuum. I shut off the gas valve, had everything hooked up, and sucked on the little tube, causing vacuum to the switch, it closed and everything worked as it should, but if hooked up to the fan and all, it still gives the pressure code. Only thing I can think of is that it means either I have the wrond style of switch, it is wired wrong to the board, or it is wired wrong from the factory. Any ideas?

Related HVAC Questions