How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Honda-Man Your Own Question
Honda-Man
Honda-Man, Honda Mechanic
Category: Honda
Satisfied Customers: 2888
Experience:  I have an Associates Degree in Automotive. 10 Years experience on all makes and models. 20 Years Honda only including factory training. Over 30 years total.
75670266
Type Your Honda Question Here...
Honda-Man is online now
A new question is answered every 9 seconds

My PGM FI light is coming on and it feels like my plate is

Customer Question

My PGM FI light is coming on and it feels like my plate is missing I checked all the Depression hit the spark check distributor I believe everything is up to par but I'm still having issues with it what do you think it might be
JA: Just to clarify, what are the exact lights you're talking about?
Customer: Pgm fi light
JA: What is the model/year of your Honda?
Customer: 87 prelude 2.0
JA: Are you fixing your Prelude yourself? What have you tried so far?
Customer: New plug wires new thermostat new water pump Cleaned the points still fills like it's missung
JA: Anything else you want the mechanic to know before I connect you?
Customer: It all started when I changed water pump and thermostat don't know why thx
Submitted: 22 days ago.
Category: Honda
Expert:  Honda-Man replied 22 days ago.

Thank you for taking time to ask your Honda-Acura question on JustAnswer. My name is ***** ***** online handle is Honda-Man I will be assisting you.

Expert:  Honda-Man replied 22 days ago.

Is the misfire only on acceleration or all of the time? What were the compression readings?

Customer: replied 22 days ago.
Yeah its all the time I'm not sure what the compression test read I just know it all started when I change my water pump and thermostat ever since then it's been running heavy and smoking a lot and it feels like it's missing I change the spark plug wires as well I clean the points in the distributor but it still feels like it's running like shit not sure what else to do from here on out
Expert:  Honda-Man replied 22 days ago.

Sorry for the delay. Was it immediately after like started it and it was running like crap? Or did it take a while? Did you remove the timing belt to do the water pump? Have you checked the codes?

Expert:  Honda-Man replied 22 days ago.

Sorry about all the questions, it helps narrow things down. As much detail as possible will help.

Customer: replied 22 days ago.
Yeah had to remove belt no havent checked codes dont knowhow
Customer: replied 22 days ago.
Yeah immediately after it stsrted running crappy
Expert:  Honda-Man replied 22 days ago.

Sorry again, customer phone call. There will be a service check connector under the hood. It has a yellowish cover and 2 wires. Remove the cover and jump the terminals with a paper clip(see attached info). The code will be flashed on the PGM-FI light(see info). Is it possible the timing belt is off a tooth or so? It will cause it to run really crappy. I would check the cam timing and get the code. The connector might be under the dash right lower corner. If you can get me the code I can tell you what it means. My suspicion is the cam timing is off since it happened right after the water pump.

Thank you,

~Honda-Man

Related Honda Questions