How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Honda
Satisfied Customers: 43873
Experience:  16 years of experience
Type Your Honda Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Driving home the other night on the interstate doing 70+,

Customer Question

Driving home the other night on the interstate doing 70+, the tac and temp gauge went out engine light came on and green key light was blinking. Went into limp home mode. Right Before that the alt. belt started squealing. We got home slowly. Having to shift really soon b/c it wont rev up at all. Today I changed the ECU and the key module still in limp home mode. Reset the ECU and still the same problem. OB scanner says no link
JA: Where exactly do you think the noise is coming from? And how long has this been going on?
Customer: thats not an answer
JA: What is the model/year of your Honda?
Customer: 2003 Honda Civic ex 1.7
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: already told you ....
JA: Anything else you think the mechanic should know?
Customer: no
Submitted: 3 months ago.
Category: Honda
Expert:  Chris (aka-Moose) replied 3 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.working after noon till just after midnight.

  • Sorry no one has helped yet.
  • Yes, you have been charged already.
  • Yes, I am aware of the time you asked your question and time I am responding.
  • I will be online a couple more hours after this post.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help.
Expert:  Chris (aka-Moose) replied 2 months ago.

When there is no communication between the data link connector and EM, that means we need to confirm all the powers and grounds to the ECM are good. Are you good with a volt a meter?

Expert:  Chris (aka-Moose) replied 2 months ago.

Hello again Chris here,

  • I am contacting you because the post has not been closed out/completed.
  • It appears you were not pleased with my help.
  • If more assistance is needed, reply and let me know, also let me know what it is you're needing to be pleased.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I never know it.)
  • You have already paid the fees to get this question answered, and I do not want you to leave having paid for something that did not meet your wants/needs and myself not receiving a feedback selection from yourself.

Thanks Chris

Related Honda Questions