How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Honda
Satisfied Customers: 34163
Experience:  ASE Certified Tech 34 years.
7276279
Type Your Honda Question Here...
Ron is online now
A new question is answered every 9 seconds

Today I have changed my. my regulator rectifier plus clean

Customer Question

Today I have changed my carburetor. my regulator rectifier plus clean gas. Runs great but starter solenoid started acting up so I replace both. Meanwhile replace electrical connections. I know the ignition coil was grounding out. But with the headlights killing my battery.imafraid its lampcoils too.i have the gx390. Type QNE2 VIN GCBCT
Submitted: 1 year ago.
Category: Honda
Expert:  Ron replied 1 year ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

You have your question listed in the Honda section, can you explain what it it you are working on please. I am not finding any listing for a landmaster. Please post back with complete details and I will try and help you with this issue.

Customer: replied 1 year ago.
Its a utv. Gx 390. 10amp charging system.
Expert:  Ron replied 1 year ago.

My information is limited on the UTV so I will have the question moved to the proper category. Some one should be along to assist you with this if they can help .

Customer: replied 1 year ago.
Bot***** *****ne is the battery is being charged but the lights drain it.
Customer: replied 1 year ago.
Problem fixed. Charging received at solenoid but not battery. Failed load test. Replace and wait. ????? Need proper prcedure and specs to check incoming ac to 10amp rectifier.