How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HondaPlatinum Your Own Question
HondaPlatinum, A Technician
Category: Honda
Satisfied Customers: 25920
Experience:  13 year honda platinum level
Type Your Honda Question Here...
HondaPlatinum is online now
A new question is answered every 9 seconds

95 perlude I.did engine swap now it wont start gettin fuel

This answer was rated:

95 perlude I.did engine swap now it wont start gettin fuel and spark what else can I it.runnin
Hi I’m Tom and I’m here to assist you with your issue today. Before I get you a fully researched answer, I have to ask you a couple preliminary questions.What year and motor was installed into the prelude?Also is the engine light on?
Customer: replied 3 years ago.
Im not even sure wat year it is the guy from the junk yard says 95 prelude but I noticed the engine.I.took out was a f222 A1 this new motor is a f22 A4 dnt kno if theres a diffrence but my check engine light comes on then goes off after 3 or 4 sec
Yes there is a definite difference and thats what your issue is .You need the correct engine and ECM Thats why its not starting.Are you able to get the correct motor?
Customer: replied 3 years ago.
This is the second motor ive gotten from them the 1st one was no.match at all but wat else can I do
You can get the correct ECM for the vehicle and the correct engine harness and the vehicle will ok and should start.These would be the next steps.Remember Im here if you need any further assistance for anything at all it will be for no further charge.Please rate excellent service so I can get credit for my help thanks.Bonuses greatly appreciated.
HondaPlatinum and other Honda Specialists are ready to help you
Customer: replied 3 years ago.

I got the other ecm thats supoosebto.go.wit this engine and it.still hasnt started is there a relearn or somethin I can do??

Did you swap the engine harness as well?Also doe the engine light stay on or flash or come on at all?
Customer: replied 3 years ago.

No I didnt swap the harness cause I realized everything matched up but the engine light comes on and goes off like before

Ok but the harness is different and even though the connectors hook up they could be for the wrong input to the ECM.Also you checked all the grounds to make sure they are secure as well as the one at the thermostat housing?
Customer: replied 3 years ago.

Yea I checked all grounds im not even gonna go thru all this hassle im.jus jus gonna pull the motor out n get another one that matches my engine

Honestly that's the best option which I stated earlier or you will continue to have problems.