How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HondaPlatinum Your Own Question
HondaPlatinum
HondaPlatinum, A Technician
Category: Honda
Satisfied Customers: 11332
Experience:  13 year honda platinum level
3827149
Type Your Honda Question Here...
HondaPlatinum is online now
A new question is answered every 9 seconds

91 honda accord, radiator fan will not work unless hard wired.

Customer Question

91 honda accord, radiator fan will not work unless hard wired. Fuses, relay and radiator fan switch are good and or new. Any ideas???
Submitted: 7 years ago.
Category: Honda
Expert:  Honda Kris replied 7 years ago.

Hi there

When you say hard wired you mean putting your own live feed down to it ?

Has the car got Air/Con does the fan work when this is switched on ?

 

Kris

Customer: replied 7 years ago.
it works when direct wired to the battery. The AC fan on the drivers side works fine. Changed out the window relay with the radiator fan relay and the windows still work thus the ralay is ok, fuses ok 2. installed a new Honda radiator fan switch in the thermo housing and still nothing.
Expert:  Honda Kris replied 7 years ago.

Does anything happen when you bridge the cooling fan switch ??

Customer: replied 7 years ago.
the fan runs fine when I direct wire the fan to the battery. I have not tried to wire it from the relay, i'm not an elec expert.
Expert:  Honda Kris replied 7 years ago.

No dont mean at the relay i mean the thermo switch you replaced unplug it then stick a wire between the 2 terminals with the ignition switch on then the fans should come on

Customer: replied 7 years ago.
to be clear, you are asking if I wired it from the radiator fan switch plug to the fan with the ignition on but engine not running. no, i have not tried that. I assume that is testing the wiring???
Expert:  Honda Kris replied 7 years ago.

yes thats what its doing,

1 thing where is the switch you replaced is it on the bottom hoes or the top hose ?

Customer: replied 7 years ago.
The bottom hose goes to the theromstat and the top hose goes to the front of the engine block. I changed the switch at the thermostat not at the block or the top hose. Also the temp guage works fine. sorrry for the delay in my response, still at work.
Expert:  Honda Kris replied 7 years ago.

Right you are at the right switch by the sounds of it,

So remove the plug from that switch on the thermostat housing and get a small bit of wire with bare both ends and push them im the end of the plug, so you are making a complete circuit. Then turn the key on and fans should cut in.

let me know what happens

 

Kris

Customer: replied 7 years ago.
Will do it tonight. Could the sensor at the front of the block/top hose be a problem or is that the temp sending unit? The temp guage does work.
Expert:  Honda Kris replied 7 years ago.

that is the the temp sensor for the ECU no need to play with that just tell it what to temp is.

If the fans dont come on then if you are able check to see if you getting a live feed to that plug on 1 of the wires

Customer: replied 7 years ago.
I'll give it a try. It sounds like we may have a wiring issue.
Expert:  Honda Kris replied 7 years ago.
The switch is a problem iv see before but not many wiring faults, just see what happens and go from there
Customer: replied 7 years ago.
Did i mention it is a new switch ($47 from Honda). The aftermarket switches would not properly fit the plug.
Expert:  Honda Kris replied 7 years ago.
Yes i see that, did you say when A/C is on both or 1 fan comes on ?
Customer: replied 7 years ago.

ok.

tested the radiator fan switch plug as suggested. Wired directly from the plug to the radiator fan. The radiator fan (passanger side fan) did not come on but the AC fan did. Tested the radiator fan motor again, it worked. plugged the radiator fan switch up again and still nothing at operating temp. What is next????

Related Honda Questions