How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask TheDoctor Your Own Question

TheDoctor
TheDoctor, Professional w/Adv. Degree
Category: Homework
Satisfied Customers: 1757
Experience:  M.S. in Internet Information Systems
59032869
Type Your Homework Question Here...
TheDoctor is online now
A new question is answered every 9 seconds

Hello im trying to create a valid schema against a preexisting

This answer was rated:

Hello i'm trying to create a valid schema against a preexisting xml file that has already been verified. My issue is that i'm having issues with creating the following attributes that fall under the element "movie". genre, stars, and rating. I keep getting an error.

<!-- please note comment was added so xml can show up in this box. below is my schema. I will add my xml in the additional information as this box does not give enough characters to add both.
Hello again and thank you for your question!

It is best if you do not enter code/XML into the question thread at all, as it doesn't always come through. This time, neither your schema nor your XML came through in the question.

Please zip up your schema and XML into a single zip file and then upload that zip file to http://ge.tt

Once uploaded, you will be given a link on the right. Click on the 'Copy Link' option and then paste that link into this thread. With that link, I will be able to retrieve your files.

Thank you
Customer: replied 3 years ago.

Thank you so much


 


http://ge.tt/66Cg8nv/v/0?c

Hello again!

Please download the files here:

DOWNLOAD

The XML now fully validates with the XSD. There were two issues that needed resolved. First, you were setting the attributes rules on the MovieCatalog element in the XSD. However, those attributes are in the Movie elements and should be defined as part of the Movie element in the XSD. I have corrected this.

The other issue is that you were using a & in your XML. When using special characters like this in XML, you must wrap the data inside of a CDATA tag. Otherwise, it will throw an error. You can see this at line 50 of the XML file.

Let me know if you have any question. I'm here to help!

If you need assistance in the future, please feel free to request me directly by starting your questions with **For TheDoctor**.

Please remember to rate my answer. Thank you so much and have a wonderful day!
Customer: replied 3 years ago.

Thank you sooooo much. You are the best!!

THIS ANSWER IS LOCKED!

You need to spend $3 to view this post. Add Funds to your account and buy credits.
TheDoctor and other Homework Specialists are ready to help you