How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie
Louie, Technician
Category: Home Theater-Stereo
Satisfied Customers: 1112
Experience:  Have been in the business 25+ yrs., down to component level.
13948492
Type Your Home Theater-Stereo Question Here...
Louie is online now
A new question is answered every 9 seconds

I've had a problem with my AVR500bt losing the hdmi inputs

Customer Question

I've had a problem with my AVR500bt losing the hdmi inputs on CBL and Media Player. Is there a way to restore them?
Submitted: 1 month ago.
Category: Home Theater-Stereo
Expert:  Louie replied 1 month ago.

Hi and welcome to the site, I’m Louie. Sorry you had to wait awhile but I’ll do my best to help.

Initially, bear with us; re-confirm and post back with the complete model number of the receiver.

Customer: replied 1 month ago.
As the original question said, its a Denon AVR500BT.
Expert:  Louie replied 1 month ago.

Appreciate the information that it is a Denon.

Might it perhaps be the Denon AVR-S500BT ?

If yes, have you tried the RESET procedure as shown HERE ?

Customer: replied 1 month ago.
I did. Didn't fix it.
Expert:  Louie replied 1 month ago.

I checked the repair/Service Manual. That a RESET was not corrective would be indicative of an internal hardware issue.

Are you then considering a DIY (do-it-yourself) repair approach? If yes, do you have access to and familiar with a multi-meter and even a soldering iron?