How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie
Louie, Technician
Category: Home Theater-Stereo
Satisfied Customers: 1086
Experience:  Have been in the business 25+ yrs., down to component level.
13948492
Type Your Home Theater-Stereo Question Here...
Louie is online now
A new question is answered every 9 seconds

We have a new kenwood stereo put it in our ford explorer we

Customer Question

we have a new kenwood stereo put it in our ford explorer we have power just no sound ... what could be the problem be thanks
JA: What's the make/model number of your stereo? How old is it?
Customer: id have to go look we only bought it a week ago
JA: What happened right before this popped up? What troubleshooting have you tried?
Customer: my hubby took it out
JA: Anything else you want the theater expert to know before I connect you?
Customer: hi we have a kmm-bt302 car stereo
Submitted: 28 days ago.
Category: Home Theater-Stereo
Customer: replied 28 days ago.
kenwood kmm-bt302
Customer: replied 28 days ago.
there is power no sound
Expert:  Louie replied 28 days ago.

Hi and welcome to the site, I’m Louie. Sorry you had to wait awhile but I’ll do my best to help.

Initially, have you checked/ensured that the Ford Explorer's speakers are directly connected to the Kenwood KMM-BT302's speaker wires?

...and/or that there is no factory installed amplifier

Related Home Theater-Stereo Questions