How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie, Technician
Category: Home Theater-Stereo
Satisfied Customers: 1065
Experience:  Have been in the business 25+ yrs., down to component level.
Type Your Home Theater-Stereo Question Here...
Louie is online now
A new question is answered every 9 seconds

Have an Altec Lansing IMT810 MIX boombox that suddenly

Customer Question

Have an Altec Lansing IMT810 MIX boombox that suddenly displayed:
DSP FW Update Required
Current: 0.00.0064
Required: 8.00.0000
It will not do anything except displaying that error. Any way to flash that to fix it?
Submitted: 3 months ago.
Category: Home Theater-Stereo
Customer: replied 3 months ago.
I'm not sure if someone was working on this. I think I changed web page, and don't see anyone now connected working on this. First time using this service, sorry.
Expert:  Louie replied 3 months ago.

Hi Chuck and welcome to JustAnswer,

Thank you for the question and your patience. Should you still need assistance for information purposes only...

Initially, have you tried if it will do a RESET?

Customer: replied 3 months ago.
Louie, thanks for your input. Unfortunately, there is no reset, nor even a USB port, or other easy access to flashing the firmware, which I'm guessing somehow got erased. It has connector for IPOD (old style connector), or two 1/8" AUX input plugs. I'm guessing there is a a circuitboard with a chip that needs to be flashed back to the correct firmware. I did see others with this problem on a Google search, but noone answered. Also, Altec Lansing has since sold out their company to a new owner who does not provide any support for legacy products....I called them yesterday.
Customer: replied 3 months ago.
This link displays exactly what I see:
Customer: replied 3 months ago.
Even the manual shown here has no information about the firmware.
Expert:  Louie replied 3 months ago.

I understand and the above post is the only easy doable attempt hence....

Have you checked / tried RESET p.8 ?

Customer: replied 3 months ago.
Louie, sorry I am not seeing a reset function anywhere in the manual I linked. Not seeing it on p. 8 ???
Expert:  Louie replied 3 months ago.

Can you please try viewing HERE ?

Customer: replied 3 months ago.
Louie, it appears to be frozen with the FW Update Required message. No response to any button, or combination of buttons, including that reset. If I disconnect power (AC and/or battery), and reconnect, I only get that same FW Update in the display. No response otherwise.
Customer: replied 3 months ago.
Any other ideas or resources you have?
Expert:  Louie replied 3 months ago.

Sorry to hear of this Chuck and if so, then as you posted, internal to the circuitry; i.e. flashing. With no firmware source and the challenge of getting hold of a one-time-use flashing jig, then no possible course of action.

Of course a possibility would be a failed peripheral circuit component to the EEPROM. Are you then considering a DIY (do-it-yourself) repair approach? If yes, do you have access to and familiar with a multi-meter and even a soldering iron?

...even if just exploratory?

Customer: replied 3 months ago.
Louie, I don't think without a firmware source that I would be able to resurrect this. The obstacle of Altec Lansing having gone out of business, and someone new buying their name with no legacy support sort of put the nail in the coffin. Just thought I would try your website, as there may have been some old engineers around who worked on this device, and had the FW source files....but it looks hopeless.Because of the specific FW error message, I'm not leaning towards a peripheral circuit as the cause.
Customer: replied 3 months ago.
I do appreciate your expertise, but I just saw the $40 charge had been put on my PayPal account, so not sure how to get it credited back.
Expert:  Louie replied 3 months ago.

Again I understand Chuck.

My participation is strictly limited to technical, repair and/or installation issues.

On the "...get it credited back..." and other billing & payment concerns, these would be best addressed by Customer Service. Please go to

Customer: replied 3 months ago.
OK, thank you sir! Have a nice rest of the weekend!
Expert:  Louie replied 3 months ago.

Good luck and thank you too for the opportunity to be able to exchange information.

Related Home Theater-Stereo Questions