How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Aric Your Own Question
Aric, Engineer
Category: Home Theater-Stereo
Satisfied Customers: 41521
Experience:  15+ years in the field. Owner of AV Installation, OEM and Repair company
Type Your Home Theater-Stereo Question Here...
Aric is online now
A new question is answered every 9 seconds

I have an NAD T775 It worked fine the last time I used it,

Customer Question

I have an NAD T775 It worked fine the last time I used it, but now all the surround sound listening mode choices like pro logic, dots, ears are unavailable to choose and I can only pick stereo or sometimes there is another choice like analog bypass depending on source. Any ideas how to fix? This is happening across multiple sources. Thanks!
Submitted: 5 months ago.
Category: Home Theater-Stereo
Expert:  Aric replied 5 months ago.
Hello, What sources are connected and using what cabling/connections please? I would suggest trying both a "soft" and a "factory reset" of the receiver. First unplug the receiver from power for 10 seconds and plug it back in. Turn it on to see if you can access other modes besides stereo (analog). If not, then press and hold the "ON" and "RTN" keys on the front panel of the receiver, simultaneously for 10 seconds. The Green "learn" LED will start flashing. Release those buttons before it stops flashing and the unit will be set to factory defaults (note: That procedure may need to be repeated up to 3 times if the first do not work). Let me know what happens please.
Expert:  Aric replied 5 months ago.
Feel free to reply back if you need more help, or want to reply back with more details. It does not cost you anything more to reply back once you've rated. Please do rate me positively (at least 3 STARS) and I will continue with you until this is sorted. The positive rating ensures I am credited for my work.
Expert:  Aric replied 5 months ago.
Do you need further assistance with this?
Customer: replied 5 months ago.
Won't a factory reset wipe out all my speaker settings,etc?
Expert:  Aric replied 5 months ago.
Yes, but right now the unit is not behaving so if you want to correct it then a factory reset is needed. As stated, first try a "soft" reset. Beyond that, yes the factory reset clears processor glitches like the one you're having.
Customer: replied 5 months ago.
No need to answer regarding wiping out all my settings. I looked online and found out the answer is yes. Do you have any other suggestions on how to resolve this? I feel like the "reboot" and "re-image" answer is not very satisfactory as I could have done that myself and already had unplugged and turned back on.
Expert:  Aric replied 5 months ago.
I will opt out since you're looking for a solution that does not exist. Good luck.
Customer: replied 5 months ago.

Related Home Theater-Stereo Questions