How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Service Tech
Category: Home Theater-Stereo
Satisfied Customers: 9507
Experience:  8+ years of professional experience
13568747
Type Your Home Theater-Stereo Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have two wi-if Polk audio speakers and I can't get them to

Customer Question

I have two wi-if Polk audio speakers and I can't get them to work? I followed the directions but maybe I'm doing something wrong? They are the Omni s2 model
Submitted: 1 year ago.
Category: Home Theater-Stereo
Expert:  Russell H. replied 1 year ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

If you have followed the directions properly and in detail, then the question is, What are you trying to run the WiFi speakers off of?

If they are to run off a device, then that device needs to have true WiFi interface capability. And if that WiFi is not inherent in the device you want to run the speakers off of, then a dongle for WiFi would presumably need to be added. But tell me more about the device you are to run the speaker off of.

Customer: replied 1 year ago.
I am trying to connect them through my iPhone 5c and using my wi-fi wireless router I have through century link my internet provider. I get as far as downloading and connecting everything but then it tells me it can't recognize my wi-fi
Expert:  Russell H. replied 1 year ago.

Do you mean that the app, on your iPhone 5c, cannot recognize your WiFi / local router ?

What is the full and exact error message about not recognizing... ?

Customer: replied 1 year ago.
Configured play-fi devices were not detected on century link 0787
This is my wi-fi
Expert:  Russell H. replied 1 year ago.

Is your WiFi router a Wireless-G model, or a Wireless-N model?

And are the Polk Audio speakers themselves Wireless-G type, or Wireless-N type?

This sort of compatibility issue can prevent usage of Wireless devices on occasion.

Related Home Theater-Stereo Questions