How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Nathan Your Own Question
Nathan
Nathan, Engineer
Category: Home Theater-Stereo
Satisfied Customers: 22648
Experience:  Custom home theater installer. Authorized dealer top brands
59725966
Type Your Home Theater-Stereo Question Here...
Nathan is online now
A new question is answered every 9 seconds

My igroove SXT use to charge my ipod but doesn't anymore....any

Customer Question

My igroove SXT use to charge my ipod but doesn't anymore....any idea why? All ports are clean and free from debris
Submitted: 1 year ago.
Category: Home Theater-Stereo
Expert:  Nathan replied 1 year ago.
Hello, I’m Nathan, and I’ll be assisting you today. My livelihood depends on your positive feedback, so your satisfaction is my highest priority. Sorry to hear you’re having trouble. Do you still get audio to play from the ipod through the dock?
Expert:  Nathan replied 1 year ago.
Which model ipod are you using?
Customer: replied 1 year ago.
Yes, it just wont charge.....I think 4th gen video one...30G
Expert:  Nathan replied 1 year ago.
But it did charge this same one previously, correct?Have you ever updated firmware (ios) on the ipod?Does it make a difference if using the klipsch via battery or AC power?
Customer: replied 1 year ago.
it did, I'm not sure if its been updated....not recently. I've only got AC power to the speakers
Expert:  Nathan replied 1 year ago.
Okay, that leaves 2 possible issues here:1) Contamination on the contacts that is preventing a charge2) A hardware failure meaning a bent/damaged pin, or defect in the charging circuitry in the board underneath the dock pins. That means the 5v output on that board or the internal power supply has failed. This is an extremely common problem with these docks, and will happen even just from normal wear and tear over the years (it is a 2008 model, so getting quite old) or could have been damaged by a power surge.The one thing you can try is cleaning the contacts. Unplug power, and turn off the ipod. Clean the metal electrical contacts/pins on the dock, and up inside the ipod by first blowing off with compressed air, then swabbing with qtips and rubbing alcohol. Dry well, power back on, and try again.
Expert:  Nathan replied 1 year ago.
If no change, it would confirm a hardware failure, unfortunately. That is not something that can be fixed economically. Klipsch never made any parts available for these, and labor alone would cost you double what you'd spend to buy a new dock.At that point, I'd recommend either using it without the charge function, or bypass the dock and run a 3.5mm/aux cable to the klipsh for sound, and a separate charge cord to the ipod to keep it powered.
Customer: replied 1 year ago.
ok thanks
Expert:  Nathan replied 1 year ago.
You're welcome. Best of luck to you, and apologies for the (potentially) bad news.If you need help finding the appropriate cords/cables, or replacement recommendations, I'm happy to advise further. If you have any other questions, just let me know. Otherwise, please do remember to rate my service prior to logging off, hopefully I have earned an “excellent”. I also invite you to contact me directly with any future support needs at http://bit.ly/1NTiEkV Thank you, ***** ***** a good day,Nathan

Related Home Theater-Stereo Questions