How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask The Home Smithy Your Own Question
The Home Smithy
The Home Smithy, Home Builder
Category: Home Improvement
Satisfied Customers: 9619
Experience:  #1 Home Improvement Expert 30+ years experience
3079445
Type Your Home Improvement Question Here...
The Home Smithy is online now
A new question is answered every 9 seconds

I have a Gecko spa. Not sure on year and model. I'm getting

Customer Question

I have a Gecko spa. Not sure on year and model. I'm getting 3 flashing dots after refilling. Was working before.
Submitted: 1 year ago.
Category: Home Improvement
Customer: replied 1 year ago.
Spa jets will turn on by itself every 20 min or so. High jets aren't coming on. Research tells me it's a flow issue but don't know how to fix.
Expert:  The Home Smithy replied 1 year ago.
Hi, and welcome to JustAnswer.You have a hi temp limit issue. Most likely you have a bad temperature sensor.To determine the problem please see the attached file for the diagnostic flow chart. If you have any questions about the flow chart please do not hesitate to post them here. I will be happy to assist you further if needed.Best Smitty
Customer: replied 1 year ago.
Heater barrel is not warm. Water temp is correct with what it says on the gage. 82, live in Ohio been upper 80's all week. What do I need to do to fix?
Expert:  The Home Smithy replied 1 year ago.
You need to replace the High limit temperature probe. Your local pool and spa supply store should have one. They are pretty common and easy to replace. Just be sure to take the model number with you.
Customer: replied 1 year ago.
Bought the new high limit probe. Same result. 3 blinking lights
Customer: replied 1 year ago.
There's a red light on the circuit board.