How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Caterpillar Engine Expert
Category: Heavy Equipment
Satisfied Customers: 8330
Experience:  23 Years Caterpillar Engine experience.
Type Your Heavy Equipment Question Here...
Cat Man is online now
A new question is answered every 9 seconds

3126 will not start without ether when cold, will start when

This answer was rated:

3126 will not start without ether when cold, will start when hot, runs fine does not cut off. Has 75 psi fuel pressure, 1440 psi high volume oil pressure, has new intake heater, high volume oil pump, ipr
Hi. Thanks for using JA! I will try and help you out.

Do you know if there are any codes in the ECM?

When your cranking, does the engine hit at all or put out any smoke? Or is there nothing while cranking?
Customer: replied 3 years ago.

no codes & nothing while cranking

Thanks for the information.

There are two things inhae seen cause this.

The first and most common is a faulty engine speed timing sensor signal. I have seen this many times. Sometimes when they fail there is a code for them but not always. Sometimes when they fail, they give an RPM signal to the ECM, but no TDC signal. When this happens, you will have good actuation pressure, a no start, and no codes. When you use either, it elevates the signal and the engine will atart. Most often the sensors even ohm good but are still bad. I would try these first. I had one like this in my shop last week.

Second is low voltage to the engine ecm during cranking. Even though the engine may turn over good, if ECM voltage drops below 7 volts, the engine will not start. But when either is used and the starter is disengaged, power comes back.

Please reply back if you need more help or have more questions. I am happy to assist.
Customer: replied 3 years ago.

we will try sensor thanks for your help

You are very welcome. I am happy to assist.

There are two of them. They come as a pair and are on the drivers side of the engine on the back of the front cover.

Make sure to inspect the harness and make sure it looks ok. Let me know if you need more help.
Cat Man and other Heavy Equipment Specialists are ready to help you

Related Heavy Equipment Questions