How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Caterpillar Engine Expert
Category: Heavy Equipment
Satisfied Customers: 8674
Experience:  23 Years Caterpillar Engine experience.
30708357
Type Your Heavy Equipment Question Here...
Cat Man is online now
A new question is answered every 9 seconds

how to remove a high pressure oil pump on a 3126

Customer Question

how to remove a high pressure oil pump on a 3126
Submitted: 4 years ago.
Category: Heavy Equipment
Expert:  Cat Man replied 4 years ago.
Hi. Thanks for using JA! I will try and help you out.

Removing the high pressure pump is not hard at all. Just disconnrect both fuel lines and both the oil lines. Then disconnnect the two wire plug on the top. The there are three bolts that hold the pump on the front cover.

Also, the pump does not have to be timed to he engine. So when you go back with the pump. Just install it in he front cover.

Please reply back if you need more help.
Customer: replied 4 years ago.
The supply line pulled blew out of the pump housing. This is an electronically controlled engine and has ruined the housing. I have to take the entire housing out so that is my question. thanks
Expert:  Cat Man replied 4 years ago.
You are very welcome.

I have seen this failure before. The threads fail in the pump housing when the fitting iss overtighted. Ne sure just to snug up the fitting in the new pump. Unfortunately, the housing on the pump can not be replaced. You will need a new pump.

Please reply back if you need more help.
Expert:  Cat Man replied 4 years ago.
Hey. I just wanted to see how things were going. Please reply back if you need more help.
Expert:  Cat Man replied 4 years ago.

Dear customer. Thank you so much for using Just answer. It has been a pleasure serving you. However I noticed that you have not given me a rating on my answer. If you are still in need of help, please, please, reply back to me. I am very happy to help.

 

The reason I am sending this note to you is because Just Answer has made some changes to the website recently and we have learned that some great customers like yourself have experienced some "bugs" in the system and the screen does not show you how or where to rate the answer you were given.

 

If this has happened to you, please place the curser over the bottom of an otherwise invisible rating box and then the choices will appear. Its a little tricky because the Smiley faces are invisible until you place you curser over this lower region and move the curser until you find where these choices light up for you. Positive ratings are the only way I receive credit for the answer.

 

Thanks again so much for using Just Answer. It is my pleasure to serve you. We are very sorry for any confusion the bugs in the system may have caused you. Have a great day!

Related Heavy Equipment Questions