How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask DR.Cummins Your Own Question
DR.Cummins
DR.Cummins, FIELD SERVICE TECHNICIAN
Category: Heavy Equipment
Satisfied Customers: 3544
Experience:  16 Years working on Cummins Diesel engines,
28984014
Type Your Heavy Equipment Question Here...
DR.Cummins is online now
A new question is answered every 9 seconds

2007 t800 kw with an isx cummins I changed both fuel filters..electric

Resolved Question:

I have A 2007 T800 KW with an ISX cummins I changed both fuel filters and filled them with fuel before installing. then turned on key to run electric pump. It did not turn on. I started truck it ran for 30 seconds and died. electric pump still wont come on. engine was running fine before service. Ichecked fuses found no problem.
Submitted: 4 years ago.
Category: Heavy Equipment
Expert:  DR.Cummins replied 4 years ago.
Hello and welcome to Just Answer! I would be more than happy to assist you today.the ecm supply's power to the lift pump. No power at the lift pump connector means there is a power issue or ecm problem, check power , keyswitch, and fuses, if all power and ground to the ecm is present than suspect an ecm problem. If there is power to the pump at key on than the lift pump is failing and should be replaced
DR.Cummins and 2 other Heavy Equipment Specialists are ready to help you
Customer: replied 4 years ago.
I'm not sure if I'm checking the lift pump voltage in the right place or if there is a fuse somwhere other than the fuse Pannel on firewall or battery box
Expert:  DR.Cummins replied 4 years ago.

There is a relay and fuses located on the engine harness by the ecm and in the battery box, There is also only 2 pins to check on the lift pump harness The pump will only run for a short time at key on. This is the only time you will see voltage.

Remove the fuel lift pump power connector at the fuel lift pump.

Insert a test lead into the fuel lift pump supply pin and another test lead into the fuel lift pump return pin on the harness connector. Turn the keyswitch on and measure the voltage with a multimeter.

The voltage must be battery voltage. If voltage is not present, check the fuse on the fuel lift pump relay supply line. Replace if necessary.

 

The lift pump ONLY RUNS AT KEY ON FOR A SHORT PERIOD. That is the only time you will hear it. Also try to activate it by bumping over the engine but not starting. It would come on that way too.

 

Related Heavy Equipment Questions