How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIX-IT Your Own Question
FIX-IT
FIX-IT, Technician
Category: Heavy Equipment
Satisfied Customers: 1185
Experience:  ENGINES-ELECTRICAL
35815791
Type Your Heavy Equipment Question Here...
FIX-IT is online now
A new question is answered every 9 seconds

My dash cluster gauges are inoperative..switch in for high beams

Customer Question

I have a 2007 Sterling Heavy duty tractor. AT9500. My dash cluster gauges are inoperative unless you have the lights on and hold the T-signal switch in for high beams. The dash indicator lights work only. None of the gauges or the LCD screen work. only with the light on and high beams. Wierd. I replaced the turn signal switch but no change. I was thinking maybe the wiper control module? Thanks.
Submitted: 6 years ago.
Category: Heavy Equipment
Expert:  FIX-IT replied 6 years ago.
Hello and welcome to just answer.i can help you with this..can i get the last 6 of your vin pls...
Customer: replied 6 years ago.
I don't have the VIN at this time. I'll have to send it to you on Monday unless I get to my office sooner. THanks. Dale
Expert:  FIX-IT replied 6 years ago.
ok keep in touch
Customer: replied 6 years ago.

Last six of the VIN is

X39067

 

Thanks. Dale

Expert:  FIX-IT replied 6 years ago.

and know the dash guages

which ones quit ? only the engine related ones or all? do they freeze or do back to zero ?

Customer: replied 6 years ago.
All gauges are inop (except air) including the display. If you turn on the lights, then work the high beam switch on, the dash works. when you turn the high beams off, the dash stops. when you turn the high beams on again, the gauges will sweep and reset to work again.
Expert:  FIX-IT replied 6 years ago.
interesting do you have a multi meter ?we have to do electrical checks.
Customer: replied 6 years ago.
Yes, I have a multimeter.
Expert:  FIX-IT replied 6 years ago.

sorry for the delay

click here

you will see the plugs labeled CL 1 and CL2

these are the plugs at the backside of your cluster

at D 14 and 15 and 16 THESE are your power ignition and ground

confirm you don't loose power or ground at these pins when it faults

let me know how you do,keep a close eye on that ground.

FIX-IT and other Heavy Equipment Specialists are ready to help you
Customer: replied 6 years ago.
Hello. I just got back to this sterling. I do not have power to # XXXXX & # XXXXX wires at the cluster. They power up to 11.2 volts only when I have the headlights and high beams on. # XXXXX has power. Ground is good. I replaced the wiper module and checked the combination switch and is ok. Let me know where to go from here. I have limited reference on Sterlings. Thanks. Dale
Customer: replied 6 years ago.
Oh, I forgot to accept your previous answer. Thanks for the info. I'll probably need followup soon. Thanks again.
Customer: replied 6 years ago.
please let me know what I should check next. Thanks. Dale
Expert:  FIX-IT replied 6 years ago.
437a comes from fuse panel fuse 48 do a power check there.let me know
FIX-IT and other Heavy Equipment Specialists are ready to help you
Customer: replied 6 years ago.
yes, power at this fuse. Thanks.
Expert:  FIX-IT replied 6 years ago.

sorry for the delay click here

go to page 4 and lets concentrate on 437a

you will see the wire come out of cavity 48 b

confirm the ignition power is there with key on and confirm its there all the time with the key on,let me know..