How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne, Journeyman
Category: Heavy Equipment
Satisfied Customers: 8279
Experience:  34 years experiance as engine rebuild and problems.Thermo-King repair and trouble shooting.
Type Your Heavy Equipment Question Here...
Wayne is online now
A new question is answered every 9 seconds

A fuel gauge problem with my Kubota L2350 tractor...sending unit

Customer Question

I have a fuel gauge problem with my Kubota L2350 tractor.. The gauge quit reading and stayed on empty all the time. I replaced the sending unit and the gauge. Now it reads accurately when the tractor is not moving , but when it is moving it flucuates wildly. I have proper voltage to the sending unit according to the shop manual (4-6 volts) at idle. Could this be a ground issue?

Thanks for your help

Submitted: 5 years ago.
Category: Heavy Equipment
Expert:  Wayne replied 5 years ago.

wayne :

Hi I'm Wayne, I will help you with this,

Expert:  Wayne replied 5 years ago.

Hi Jim,

OK lets start here from beginning.......
I f you have sending unit out of tank, and move arm, the gauge will read the amount.....correct.

You do have a proper voltage ,
But one thing that concerns me is the ground wire at sender clean and tight ....

Then the next thing is a loose connection in harness, a plug vibrating as you drive

Let me know
Wayne and 2 other Heavy Equipment Specialists are ready to help you
Customer: replied 5 years ago.

The tractor is out at my ranch and i wont be going out there for a couple of weeks. Now that i think about it i believe that the loose ground connection might be the problem. i will work on it next time out there and let you know.


Thanks for the help Wayne

Customer: replied 5 years ago.
i was out an my ranch this weekend and i found that the ground in the wiring harness was loose. i reconnected it and it works like a champ,

thanks for your help

Expert:  Wayne replied 5 years ago.

Mornking Jim,

glad to hear it, you are welcome

wayne Cool

Related Heavy Equipment Questions