How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JohnnyFixIt Your Own Question
JohnnyFixIt
JohnnyFixIt, Technician
Category: Heavy Equipment
Satisfied Customers: 7
Experience:  4 years Rental industry Technician, 8 years Farm Fleet technician, 10 years Landscape equipment
32623159
Type Your Heavy Equipment Question Here...
JohnnyFixIt is online now
A new question is answered every 9 seconds

hi i have a takeuchi 130 loader it will start for a second

Customer Question

hi i have a takeuchi 130 loader it will start for a second then quit. there is a operator lite on looks like a upside down bulb with wavy lines in it then a / mark another upside down bulb with a tear drop inside it an a arrow on each side of the bulb what does this mean?
Submitted: 5 years ago.
Category: Heavy Equipment
Expert:  JohnnyFixIt replied 5 years ago.
Hello my name is John.

The warning light you are referring to is the low coolant level/ low oil psi shutdown system. The tl130 has a common problem of getting air in the cooling system right at the coolant level sensor in the upper radiator hose or the sensor itself going bad. This will cause the start and die symptoms you are having. First make sure the coolant in radiator is full (only check when engine is cool) and shake upper radiator make sure there is no air in the hose. You can check if sensor is bad by putting a jumper wire in the sensor plug going to the engine harness, if the light goes out and engine runs you have a bad sensor.

I dont think you have an oil psi problem but make sure oil is full and you have changed your oil filter, but i rarely see oil problems with the yanmar engine.

Related Heavy Equipment Questions