How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Clayton Your Own Question
Clayton, Mechanic
Category: Heavy Equipment
Satisfied Customers: 755
Experience:  5+ Years at Freightliner, Detroit & MBE Certified, ATD, and Electrical
Type Your Heavy Equipment Question Here...
Clayton is online now
A new question is answered every 9 seconds

hi,i have eaton smart shift transmision and it is giving me

Customer Question

hi,i have eaton smart shift transmision and it is giving me problems with shifting.sometimes it is working properly and sometimes it just wont go in at all.i ussually stop the trusk turn it of and than do the reset ,ahd after that i am ok for a while.(sometimes 100 miles,sometimes just 2 or 3).truck make is frghtl century 2005.most frequent problem is downshifting from 10th the place on monitor where is suppoused to be number of the gear that i am in,it is showing letter f that is coming and going of instead of the number.
Submitted: 6 years ago.
Category: Heavy Equipment
Expert:  Clayton replied 6 years ago.
Hi, I'm Clayton. I can help you.

The letter "F" that is showing up is indicating you have a fault code during the time of failure. Your local Freightliner can pull this code with the Eaton Software. You might can get this code from the driver display on the dash.

I have heard of these symptoms before. What the dealership will probably do is an electrical pre-test. This is something you can do to save some guess work. These smart shift transmissions are tricky. I have seen a bad battery cause this. I have worked on trucks where Eaton was actually throwing parts at it to fix the truck. Parts that were replaced was the X-Y shifter, Trans Harness, and finally an ECU.

Eaton transmission are also notorious for there trans harness rubbing through on the side of the transmission case.

I would check for corrosion on battery terminals, and have your batterys checked first. Eaton will want the dealership to clean and check the batterys first thing. .
Customer: replied 6 years ago.
thank you clay.i wil contact u
Expert:  Clayton replied 6 years ago.
If this has helped you, please hit the green accept button :o)

If you have any more questions, I am here to help you.
Customer: replied 6 years ago.
i clean the battery terminals but problem is still ocuring.indicator for battery shows 14 while driving and 12.3 on start
Expert:  Clayton replied 6 years ago.
Alright. Lets see here.

Have you checked the batteries?. One battery that has failed can cause this. All the batterys need to be in good working order. The batteries need to be load checked.

Also clean and check the frame grounds. If all of these are OK, Then you are looking at either a TCU problem, or an X-Y Shifter(located on top of the transmission)

If this does not help, Im afraid if you take it to a dealer, unless the guy is VERY experienced with these transmissions,he may have a hard time pin pointing the problem as well. Which may lead into throwing parts at it.

OH!, I almost forgot. If the Eaton Software in the TCU is out of date, there is an update to reprogram the TCU that fixes a lot of troubles. And only a dealer can do this for you.
Clayton and other Heavy Equipment Specialists are ready to help you
Customer: replied 6 years ago.
i am not getting any codes,tech checked batterys all are 13.8,
Expert:  Clayton replied 6 years ago.
I would take it to your nearest dealer, have them see if the software is up to date, then go from there.

Related Heavy Equipment Questions