How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Allisonforeman Your Own Question
Allisonforeman
Allisonforeman, Transmission foreman
Category: Heavy Equipment
Satisfied Customers: 300
Experience:  Factory trained by Allison Transmission on all on Hwy products including the Hybrid Electric drive,
26133040
Type Your Heavy Equipment Question Here...
Allisonforeman is online now
A new question is answered every 9 seconds

I HAVE AN AT545 ALLISON TRANSMISSION IN A 1999 MODEL YEAR INTERNATIONAL

Customer Question

I HAVE AN AT545 ALLISON TRANSMISSION IN A 1999 MODEL YEAR INTERNATIONAL (NAVISTAR) SCHOOL BUS. ITS PROBLEM IS IN THE UPSHIFTING TO A HIGHER GEAR. FOR EXAMPLE, IF IT IS PLACED IN THE '' DRIVE'' POSITION AND THE ACCELERATOR IS DEPRESSED, IT USUALLY STAYS IN ''FIRST'', ''SECOND'' OR ''THIRD'' GEAR. SOMETIMES IT SHIFTS TO THE ''DRIVE'' POSITION IF ONE ''PLAYS'' WITH THE ACCELERATOR PEDAL. THERE ARE 5.43 VOLTS ON THE POWER (TAN) WIRE GOING TO THE SOLENOID ON THE TRANSMISSION. WHAT IS THE PROBLEM?
Submitted: 6 years ago.
Category: Heavy Equipment
Expert:  Allisonforeman replied 6 years ago.
Hello and thanks for using Just Answer,my name is XXXXX XXXXX I would like to help you with your question. The newer model AT 545 uses an electric modulator instead of a vacuum or mechanical style modulator. The modulators function is to let the transmission valve body know when the throttle position is above 60% throttle or so. When the system is operating properly there will not be any voltage until the throttle is opened 60% or more,"then there should be a full 12 volts".If there is voltage at all times"although 6 volts is somewhat low"the transmission will not want to shift at part throttle conditions". A simple check you can do is to disconnect the connector at the modulator and test drive at no more than 1/2 throttle,if the transmission now shifts the relay is probably failing. If the transmission is the original,I would suspect a stuck governor. It is located on the drivers side toward the rear of the transmission behind a cover with 4 bolts on it,you can remove the governor,hold the weights in and shake it up and down,you should hear the valve inside move up and down freely,if it is stuck it could also cause your concern,"Although I would still address the voltage at the modulator too"
I hope this information helps ,Let me know if you need any further information.
Bill
Allisonforeman and other Heavy Equipment Specialists are ready to help you