How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Allisonforeman Your Own Question
Allisonforeman
Allisonforeman, Transmission foreman
Category: Heavy Equipment
Satisfied Customers: 300
Experience:  Factory trained by Allison Transmission on all on Hwy products including the Hybrid Electric drive,
26133040
Type Your Heavy Equipment Question Here...
Allisonforeman is online now
A new question is answered every 9 seconds

LIGHT COME..REVERSE NO PROBLEM, REPLACED TRANS HARNESS AT SOLENOIDS

This answer was rated:

HAVE A 2001 INTERNATNAL 4700 TOW TRUCK , THE SHIFT INHIBITOR LIGHT COME ON, & GO IN TO NUTRAL, NO DRIVE, HAS REVERSE NO PROBLEM, REPLACED TRANS HARNESS AT SOLENOIDS, & SELECTOR SWITCH,CHANGE FILTER. & FLUID, MO METAL ON MAGNET OF OIL FILTER. NOT ABLE TO RETRIVE CODES.

Hello and thanks for using Just Answer my name is XXXXX XXXXX I would like to help you with this question.Without knowing what your diagnostic codes are all i can do is suggest what I would check first. You have a good reverse but no forward range from neutral 1)First is to make sure the linkage adjustment is dead on "Because in forward the C-1 clutch is fed directly through the selector shaft connected to the linkage. 2) second I would take a good look at the Pressure switch on the valve body,It will be bolted to the bottom of the valve body,and there will be a transfer tube that has a bracket bolted over it, colors can be black"Old style" or Blue "New style. The o-ring for the reverse part of the switch has a nasty habit of popping out of its groove. Also the valve body E shift valve can stick open or closed and cause concerns going into forward or reverse,working from where the harness goes through the main case and not counting the solenoid on the top of the valve body,it will be the 3rd from the end,next to a solenoid that looks exactly the same.You can removed the solenoid and make sure the valve moves freely."DONT REMOVE the bracket that holds the 2 solenoids closet to the harness pass through, they are very difficult to get back in place properly. If you had no clutch material in the pan,I agree your clutch packs should be fine. Diagnosing your concern would be much faster if you can find someone to read your diagnostic codes with Allison software.

This should be enough info to go as far as you can.

Thanks Bill

Allisonforeman and 3 other Heavy Equipment Specialists are ready to help you
Customer: replied 7 years ago.
Thank you for the information,I hook up a lab scope to check speed sensor,turbine sensor, compare to another truck in shop, replace pressure manifold, hook up pressure gauge to main tap, 250 psi, try anoyher pcm, no change, working on access dtc , I have snap-on heavy duty Truck software, i can access engine control but not transmission control. at the piont , i may have internal fault, all external sensor check good. I will work scanner info to retreive codes, Thanks.