How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Greg A. Your Own Question

Greg A.
Greg A., Engineer
Category: GPS
Satisfied Customers: 8093
Experience:  Using & Working with GPS systems for 10+ years
5229702
Type Your GPS Question Here...
Greg A. is online now
A new question is answered every 9 seconds

I have a nevi 2589. It has lifetime map updates. I am unable

Customer Question

I have a nevi 2589. It has lifetime map updates. I am unable to update to the 2017 North America map. All other updates came through no problem. Any suggestions?
JA: What's the make/model of your GPS unit? How old is it?
Customer: Purchased in 2015. Unit ID(###) ###-#### Nuvi 2589.
JA: What happened right before this popped up?
Customer: Had 10 updates. 9 went through. 10th, the big one, did not. It just chugged.
JA: What troubleshooting have you tried?
Customer: Tried different USB cable attachments. Restarted my Mac.
JA: Anything else you want the GPS expert to know before I connect you?
Customer: Sure. Knew it was a big file, so left it
Submitted: 1 month ago.
Category: GPS
Expert:  Greg A. replied 1 month ago.

Hello & Welcome to Just Answer,

Sorry to hear of any issue you are having with your device.

To help you with this issue, may I ask:

1) Is this the FIRST time you have tried to update the device?

2) What tool (program) are you using to update the device?

3) When you say "it just chugged" - what does that mean (sorry if I don't understand that term)?

Thanks

Customer: replied 1 month ago.
Not the first time. Using Garmin Express application. By "chugged" I mean it sat there with the spinning circle spinning away, but no progress on download of 211 files indicated even after prolonged time.
Expert:  Greg A. replied 1 month ago.

Hi again and thanks for that information.

OK - can I assume this was during the Map update attempt, or was there something else going on?

And did you see ANY "progress bars" - similar to what was seen for the other updates?

Also, was Garmin Express UPDATED - to the latest version?

One more thing - had the device been REMOVED from the computer and REBOOTED - before this last attempt was tried?

Thanks

Customer: replied 1 month ago.
Just a routine update.
Progress bar visible, but no progress showing, even after considerable (hours) time.
Think it's latest version of Express but will confirm.
Yes. Full reboot done as part of my attempts to resolve problem.
Expert:  Greg A. replied 1 month ago.

OK - this "sounds like" it may be something to do with the internet connection - between your location and the Garmin servers.

May I ask the SPEED of your internet connection - if you know it?

Have you had or noticed ANY "internet connection" issues at all recently (like disconnects & reconnects)?

Also, are you "hard wired" to the internet connection, or using WiFi?

Customer: replied 1 month ago.
Think I found an answer. Appears Garmin servers are down at the moment...
Expert:  Greg A. replied 1 month ago.

Hi again,

You may be right, but it MAY just be general "internet connections" and speed right now.

I was trying to run some "network checks" - across the US - and I'm noticing some disappointing (slow & unstable) results right now.

Customer: replied 1 month ago.
Thanks. I'll try again later.
Expert:  Greg A. replied 1 month ago.

You're quite welcome.

That sounds like a good plan.

I will check back with you later - to see if this has cleared up, but in the mean time I would WAIT for this internet issue to settle down.

Expert:  Greg A. replied 1 month ago.

Hi again,

I see it has been a while and I haven't seen a response on this page, so I just wanted to follow up to see if you have any more questions concerning this issue OR if the issue was resolved?

I only ask because I saw quite a few "network issues" yesterday (denial of service and DNS), but they seem to have calmed down today.

I look forward to any further questions or results that you may have.

Thanks, ***** *****
--. .-
(im)