How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Greg A. Your Own Question

Greg A.
Greg A., Engineer
Category: GPS
Satisfied Customers: 2260
Experience:  Using & Working with GPS systems for 10+ years
Type Your GPS Question Here...
Greg A. is online now
A new question is answered every 9 seconds

I have an edge 705 that recently stopped acquiring

Customer Question

I have an edge 705 that recently stopped acquiring satellites. It shows GPS 0.00 - The software version is 3.30. Can you help me get this thing back working?
JA: Just to clarify, what's the brand and model of the GPS?
Customer: it is a garmin edge 705
JA: What happened right before this popped up?
Customer: I changed the battery
JA: What troubleshooting have you tried?
Customer: i have done a master reset
JA: Anything else you want the GPS expert to know before I connect you?
Customer: no
Submitted: 22 days ago.
Category: GPS
Expert:  Greg A. replied 22 days ago.

Hello & Welcome to Just Answer,

Sorry to hear of any issue you are having with your device.

To help you with this issue, may I ask:

1) The AGE of the device?

2) WHEN this issue first began (or was noticed)?

3) What is the condition of the battery used in this unit?

4) Did the Master Reset actually occur - to where the device was cleared back to factory defaults?

Please use the REPLY box below.


Customer: replied 22 days ago.
item is from new in 2009. the issue was just noticed on the weekend when I replaced the battery. This is the second battery replacement that i have done sonce 2009. battery is brand new. I really did the master reset several times.
Customer: replied 22 days ago.
Expert:  Greg A. replied 22 days ago.

OK - its good to know it has a new battery.

Expert:  Greg A. replied 22 days ago.

After the battery was replaced that the device reset, HOW LONG did you leave it OUTSIDE - to be able to catch the satellite signals?

Customer: replied 22 days ago.
i left it outside on a sunny clear day for hours (until the battery drained). It seemed to be stalled on the acquiring satellites process.
Expert:  Greg A. replied 22 days ago.

OK - during that time, did you take a look at the "satellite page" - and if so, did you see ANY signal bars at all?

Customer: replied 22 days ago.
no signal bars appeared
Expert:  Greg A. replied 22 days ago.

OK - that's not good.

Can I assume it was working well - JUST BEFORE the battery change - or was it failing BEFORE the battery was replaced?

Expert:  Greg A. replied 22 days ago.

And may I ask HOW LONG did the battery last - when left outside (assuming you fully charged it up before leaving it there)?

Customer: replied 22 days ago.
it was working before the battery change. My wife was doing a triathlon on Aug 21st near Montreal. The date and time of the unit is still showing it as August 21st at 11.30 am from that race. The lack of a satellite is preventing the unit from updating the time and date
Expert:  Greg A. replied 22 days ago.

I understand. That is correct that the satellite signals are needed to display the correct time.

Expert:  Greg A. replied 22 days ago.

Just to clarify - when you say you replaced the battery, you are referring to the INTERNAL battery that powers the unit - is that correct?

Customer: replied 22 days ago.
Expert:  Greg A. replied 22 days ago.

OK - if the device quit working AFTER the battery replacement, it MAY be that one of the cables inside came loose - like the flex cable between the two halves of the unit.

Have you opened the device up again, to check those cables?

Customer: replied 22 days ago.
No I have not opened the unit.\The battery works: there is power to the unit and it powers up. I can get to all the sub menus and I can input parameters and they are saved. The unit works from that standpoint. My issue is with the satellite location routine
Expert:  Greg A. replied 22 days ago.

I understand that the unit is working - almost.

My concern is ANY loose cable - that could have occurred when the battery was replaced.

My FIRST step in troubleshooting this issue would be to take the device apart and do a CLOSE examination of ALL connections inside the unit. I would even "gently pull" on each cable or connector - to see if anything is loose inside.

Does that make sense?

What we are looking for is something that might effect the RECEPTION of the satellite signals.

Customer: replied 22 days ago.
Thanks Greg.
I am going to stop there.
All connections are fine - I have done this before with the correct tools.\
This is a software issue and i do not think you can help.
Please confirm that I do not get charged for this dialogue.\Thanks
Expert:  Greg A. replied 22 days ago.

Any question about "charges" or site operation needs to be sent to customer service.

If you believe this is a software issue, may I ask if you have attempted to UPDATE the software yet?

If so, what tool (program) was used to do that?

Customer: replied 22 days ago.
I have used garmin express, garmin webupdater. I have reformatted the garmin unit utself and re-installed the software update and firmware. I have read through countless forums..
OK I will contact customer service.
Thanks for your help
Expert:  Greg A. replied 22 days ago.

You're quite welcome.

NOTE: As a "troubleshooter" of all kinds of different products, some that include software and some not - what I usually look for is "what last changed" - right before and after the symptom began.

So you MAY want to consider opening the device again and taking a look inside.

Good Luck & Take Care, Greg A.

Customer: replied 22 days ago.
Thanks for the advice
Expert:  Greg A. replied 22 days ago.

You're welcome.

Please let me know if you DO decide to take a look, and if anything changes after reassembly.

Take Care, Greg A.