How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Greg A. Your Own Question

Greg A.
Greg A., Engineer
Category: GPS
Satisfied Customers: 7946
Experience:  Using & Working with GPS systems for 10+ years
Type Your GPS Question Here...
Greg A. is online now
A new question is answered every 9 seconds

My vista hcx doesn't show any topography, just yellow

Customer Question

my vista hcx doesn't show any topography, just yellow screen. Has my way points and lat-long co-ordinates change, but no map.
JA: What's the make/model of your GPS unit? How old is it?
Customer: Etrex Vista HCX 7 or 8 yrs?
JA: What happened right before this popped up?
Customer: Nothing happened. It marked a camp site sunday night, then monday night trying to mark a waypoint, it gets no map.
JA: What troubleshooting have you tried?
Customer: Tried calibrate, then removed batteries for 30 min. Back home from hunting, still no luck.
JA: Anything else you want the GPS expert to know before I connect you?
Customer: That's all I have.
Submitted: 25 days ago.
Category: GPS
Expert:  Greg A. replied 25 days ago.

Hello & Welcome to Just Answer,

Sorry I didn't see your question earlier and to hear of any issue you are having with your device.

To help you with this issue, may I ask:

1) Do you still see ONLY yellow when you zoom OUT for the display?

2) Do you have a microSD card installed in the device and if so, what is its capacity?

3) If you do have a memory card installed, please try powering down the device, remove the card, and then power back up, then let me know what you see at that time.

Please REPLY below.



Customer: replied 25 days ago.
1) Just yellow, shows the hiway & interstate, no sidestreets, topo, or details. 2) 2gb sd card. Cleared all the waypoints, shouldn't be a capacity issue. 3) Pulled the card & power on, still yellow. Just re-inserted card & power on, still no change.
Expert:  Greg A. replied 25 days ago.

Hi again and thanks for those details.

Yes, 2GB sounds about right for the card, but I wondering IF the card still has the data on it OR if the device can not access that card for some reason.

This is because you saw NO DIFFERENCE with the card remove, and then when replaced in the device.

So may I ask if and when the device was last updated (for the software that drives it)? This will of course NOT fix any issues that may be HARDWARE related, but it is something we can try.

Also, do you have a card reader available on your computer, and can CHECK to see if there is ANY data on that card?

Expert:  Greg A. replied 22 days ago.

Hi again,

I see it has been a few days and I haven't seen a response on this page, so I just wanted to follow up to see if you have any more questions concerning this issue OR if the issue was resolved?

I look forward to any further questions or results that you may have.

Thanks, ***** *****
--. .-