How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask MasterFixIt Your Own Question

MasterFixIt, Technician
Category: GPS
Satisfied Customers: 8980
Experience:  I have 12 years of experience servicing all GPS models.
Type Your GPS Question Here...
MasterFixIt is online now
A new question is answered every 9 seconds

I have a garmin 510 i have lost my cadence and heart rate on

Customer Question

i have a garmin 510 i have lost my cadence and heart rate on my screen but still have timing,speed and distance but the screen is in a different format. i can't get full screen back with every feature i had previously.
Submitted: 7 months ago.
Category: GPS
Expert:  Pete replied 7 months ago.

Hi David,

Go into the menu settings for Activity Profiles, and ensure auto scroll is turned on.

The display should now cycle through all of the different measurements - let me know if that works for you?


Customer: replied 7 months ago.
there is no "on" in auto scroll only "slow" or "fast".I tried these, did not work.
Expert:  Pete replied 7 months ago.

Ok, let me see if the other experts have any idea on this...

Expert:  MasterFixIt replied 7 months ago.

Hi the other technician oped out. I am Tech Michael.

How old is your Garmin 510?

Also as this problem happened due to a failed update or just after a software update?

Customer: replied 7 months ago.
garmin 510 purchased nov 2015.This change in screen simply appeared as I switched on garmin to go for a ride a week ago. Not aware of failed or software updates. In the connection page the following icons appear on: heart, wheel & cadence sensors which means heart rate ,speed & distance and cadence should be working. I feel wheel sensor(ie, speed & distance) is working because they appear on current screen when riding. I feel wheel and cadence sensor have not paired . I have followed all pairing instructions by garmin.
Expert:  MasterFixIt replied 7 months ago.

Hi, thanks for that.

I have done some research on this one and yes there have been a few failed units out there that failed in this manner.

Unfortunately this is an electronic component failure, and this Garmin will need service to repair the problem.

But since your Garmin is so new it is still under warranty you can have it replaced or repaired, I woudl opt for replacement since it is so new and already has a problem;-)

They will offer that to you when you call.

The best way to accomplish this is to use the phone contact info that came with your Garmin, its should be on the warranty card and win your user manual.

Alternatively you can call Garmin Repair @: (800)(###) ###-####or(###) ###-####/p>

In any case, I will stick with you until this is complete.

Please rate my service thus far.

Also it is the only way I am credited for my time and expertise with you.

Once you rate, I will be notified and will add your question to my priority list so you can reach me anytime until this problem is solved.

Then you can reach me by simply replying to this message anytime.

Thank you and have a great day!

Tech Michael