How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Greg A. Your Own Question

Greg A.
Greg A., Engineer
Category: GPS
Satisfied Customers: 8100
Experience:  Using & Working with GPS systems for 10+ years
5229702
Type Your GPS Question Here...
Greg A. is online now
A new question is answered every 9 seconds

I received a Magaellan RoadMate 9055-LM. I have called

Customer Question

I received a Magaellan RoadMate 9055-LM for Christmas. I have called several time to get help with technical support. My machine once came on once and I have not been able to turn it on again.
I have called numerous time, waiting from 20-48 minutes to get someone to help me. I have only being able to talk to a live person twice. I was told by person #1 to register my Magellan online. His directions did not work. On my second call I was told to go online to***@******.*** and to put acct #EC4294376 in the subject line. I did this today. When I did the web address of POPetc I did not get a subject line. PLEASE can a real live person help me register my Magellan and the get it fixed so that I have this machine to use. I am a senior citizen and not very tech aware. I need help getting registered and getting help fixing my machine.
Submitted: 10 months ago.
Category: GPS
Expert:  Greg A. replied 10 months ago.

Hello & Welcome to Just Answer,

Sorry I didn't see your question earlier and to hear of any issue you are having with your device.

To help you with this issue, may I ask:
1) Have you connected the device IN YOUR VEHICLE yet, using the Vehicle Power Adapter?

I only ask because these devices have a very small capacity internal battery, and they are intended to be run MOSTLY when connected to the power in your vehicle.
2) When you turned it on for the first time, how long did it stay on, before you shut it off OR it turned off itself? Again, I only ask because of the SMALL capacity of the internal battery (specifications say it will last only about 30 minutes when fully charged).

As for the "web address" you mentioned above, that actually looks like an EMAIL address.

And when you mentioned putting that account number in the "subject line", that sounds like an EMAIL function too. So I believe that person was trying to have you register the device VIA EMAIL.

So if you were/are trying to register your device via email, I would recommend composing an email with that "address" in the "TO:" field, and the Acct# ***** in the "Subject:" field, and also a brief note in the BODY of the email (blank emails are not good and sometimes mistaken for email spam).

The Body should say something like:

"I'm trying to register my Roadmate 9055LM with this email. Please REPLY when you receive this note, so that I know you have it. Thank You"

Now back to the unit NOT turning on a second time. I suspect that the internal battery MAY not have been charged up fully (recommended initial charge time is AT LEAST TWO HOURS - using an optional AC Power adapter OR the Vehicle Power Adapter), and therefore would not power up again.

So I recommend that you DO connect the device IN your vehicle, making sure that the Vehicle power adapter is getting power from whatever power outlet you have it connected to, and leave it connected for AT LEAST AN HOUR or TWO, and then try to turn the device ON again.

If the device DOES come on, then you should be OK to continue to use the device.

NOTE: SOME vehicles MUST have the ignition turned ON to supply power to the power outlet.

One other IMPORTANT ITEM: Almost ALL GPS units do NOT need to be "registered" to operate properly. That is because most of these unit are "ready to operate" (once charged) - right out of the box.

So please try:

1) Sending that EMAIL I mentioned above, and

2) also try connecting your device to power for AT LEAST an hour or two, and then try to turn it ON - to see if a low charged battery is the issue.

Please let me know what happens when you try these things, or if you have any more questions.

If this works to get your device running and has answered your question(s), please take a moment to rate MY service level (Excellent is my goal) so that I get credit for helping you with this question.
You should see some "smiley faces" or "stars" to do that, but please let me know if you do NOT see them (you may have to scroll UP or DOWN) or can not use them.

Thanks, ***** *****
--. .-
(im)

Expert:  Greg A. replied 10 months ago.

Hi again,

I see it has been a few days and I just wanted to follow up to see if you have any more questions concerning this issue or if the issue was resolved.

I look forward to any further questions or results that you may have.

Thanks, ***** *****
--. .-
(im)

Customer: replied 10 months ago.
This last Wed. I drive my vehile for 1 1/2 hours with the Megellan plugged in. The charging cord showed a green light, so I am sure there was power to it. It will still not turn on.
Expert:  Greg A. replied 10 months ago.

Hi again and thanks for that information.

OK - now that the device SHOULD have been charged, please try the following "reset" process.

NOTE: Try this FIRST when the device is disconnected from power - or any other connection. THEN (if needed), try connecting the device to the Vehicle power adapter and repeat the process.

To "reset" the device, push and HOLD the power switch to the ON/OFF position - for AT LEAST 30 seconds. Continue to HOLD the switch for up to 60 seconds.

If the screen comes ON, release the power switch and see if the device powers up completely.

Please give that a try and let me know your results.

Thanks, ***** *****

(im)