How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask KALAMYKID Your Own Question
KALAMYKID
KALAMYKID, Shop owner, tech
Category: GMC
Satisfied Customers: 3729
Experience:  HAVE OWNED MY OWN SHOP FOR OVER THREE YEARS. I HAVE THE TOOLS AND SOFTWARE TO ANSWERE ALMOST ANY QUESTION CORECTLY.
5629372
Type Your GMC Question Here...
KALAMYKID is online now
A new question is answered every 9 seconds

We just got done doing an engine rebuild due to oil pump

Customer Question

We just got done doing an engine rebuild due to oil pump failure. Now with refreshe engine i am still getting low oil alarm when stopped at a light after engine has been running for 30 min on the highway. It is an 2007 yukon denali xl with the 6.2. We had block cleaned, new bearings new (went with L9 cam), replaced everything but the pistons and valves (did lap them)(did do new rigs and cross hatch), vvt delete, went with high pressure oil pump and this was the same issue we had before rebuild. Do we need to chanfe to a thicker oil because of wear and tear? Has 169k miles.
JA: Just to clarify, what are the exact lights you're talking about?
Customer: Check oil pressure with the ding alarm
JA: What year is your MINI?
Customer: 2007 yukon denali xl
JA: Are you fixing your MINI yourself? What have you tried so far?
Customer: We had the computer shipped to texas for programing. Other than that. We changed break in oil and still having same issure
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 18 days ago.
Category: GMC
Expert:  KALAMYKID replied 18 days ago.

Did you replace the cam bearings as well?

Customer: replied 18 days ago.
Expert:  KALAMYKID replied 18 days ago.

Did you clean out the oil cooler?

Customer: replied 18 days ago.
we cleaned and or replaced everything but pistons and valves. We did lap vaves and new rings on pistons.
Expert:  KALAMYKID replied 18 days ago.

If you did a proper rebuild, then you will not want to go to a heavier oil. Also there has to be a leak in the oil system, or the cooler or cooler lines are stopping up. So you replaced the radiator and oil cooler lines?

Customer: replied 18 days ago.
No, flushed radiator, did change lines.
Expert:  KALAMYKID replied 18 days ago.

Did you blow the lines out both directions?

Customer: replied 18 days ago.
No oil leaks anywhere
Expert:  KALAMYKID replied 18 days ago.

What brand oil filter are you using?

Expert:  KALAMYKID replied 18 days ago.

Did you replace the lifters and cam?

Customer: replied 18 days ago.
K &n yes we "upgraded" to the L9 cam and also did a vvt delete with new timing chain.
Customer: replied 18 days ago.
Castrol full synthetic 5w30
Expert:  KALAMYKID replied 18 days ago.

Did you do any work on the crank shaft? Did you plasti gauge the bearings before you did your final assembly on the block?

Customer: replied 18 days ago.
Crank was good.
Customer: replied 18 days ago.
Failure happened in driveway so no damage was done except pump. Did other work just because we had the motor out, the oil gully plug in the back broke too
Expert:  KALAMYKID replied 18 days ago.

Just because the crank looked good, does not mean there was no wear. Did you plasti gauge the bearings rod and mains?

Expert:  KALAMYKID replied 18 days ago.

Did you replace the oil pressure relief valve in the oil pan?

Customer: replied 18 days ago.
No I didn't I thought it was just an oil level sensor
Expert:  KALAMYKID replied 18 days ago.

On the inside of the oil pan there is a pressure relief valve. If it goes bad, you can loose oil pressure. Here is a diagram of the valve. If you did not replace it, you will need to drop the pan and replace it. I would plasti gauge the bearings as well if you have the pan off just to make sure the clearance is good.

Customer: replied 18 days ago.
We cleaned the valve up but If the valve is replaced and we know the clearance is good would there be anything elsecausing issues?
Expert:  KALAMYKID replied 18 days ago.

If you have low oil pressure, there has to be a leak in the system. This will have to be a leak between the cam and cam bearings, rod bearings and crank, or main bearings and crank. You need to pasti gauge the bearings to double check, and the relief valve needs to be replaced as well. I do not care if I have all new parts, when I build an engine I double check everything. You will be surprised at how much of a problem a couple thousand's of an inch can cause low or no oil pressure.

Related GMC Questions