How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gm Tech (Cam) Your Own Question
Gm Tech (Cam)
Gm Tech (Cam), GMC Mechanic
Category: GMC
Satisfied Customers: 1668
Experience:  GM Grand Master Technician 2007. 14 year experience.
10949255
Type Your GMC Question Here...
Gm Tech (Cam) is online now
A new question is answered every 9 seconds

On my 2005 envoy the rear wiper and defrost and fobs work

Customer Question

On my 2005 envoy the rear wiper and defrost and fobs work intermitantly it seems there is a short garage says the module doesn't communicate can't find ground
Submitted: 3 months ago.
Category: GMC
Expert:  Gm Tech (Cam) replied 3 months ago.

Welcome. I am Cam.
Let me get that info for you. While I look that up, have you checked the wiring in the boot that runs from the body to theliftgate itself? That were can break from usage.

Customer: replied 3 months ago.
looks fine
Customer: replied 3 months ago.
I found out it will work for a while u don't touch the vehicle minutes later it doesn't work
Expert:  Gm Tech (Cam) replied 3 months ago.

Ok, the ground is located under the trim on the right rear of the cargo compartment.
IF the wiring is good, then its possibly the module itself. They are prone to issues and corrosion.

Customer: replied 3 months ago.
I was at a fm dealership with two modules he said the module was good but it said it couldn't communicate
Expert:  Gm Tech (Cam) replied 3 months ago.

Ok, so if it will not communicate, we need to check 3 things

Power,
Ground
Data line.
If any of those are out, then this would be the result. Did they do any of those checks? ?

Customer: replied 3 months ago.
ER rear passenger side
Expert:  Gm Tech (Cam) replied 3 months ago.

I Am not sure what your asking in your last reply.

Customer: replied 3 months ago.
He was checking the module but he was an ass which side pas or dr rear
Expert:  Gm Tech (Cam) replied 3 months ago.

Right is Passengers side.

Customer: replied 3 months ago.
Ok
Customer: replied 3 months ago.
Wires donor go to passenger side they go drivers side
Expert:  Gm Tech (Cam) replied 3 months ago.

The wiring goes down the drivers side and back to the passengers side. Its callout #3 in the picture. Check #9 as well on the drivers side.

Customer: replied 3 months ago.
Does the rear latch act as a ground? Also I heard orange wire at top lift gate could be problem my tech says module is not communicating which plug into module is the data line
Expert:  Gm Tech (Cam) replied 3 months ago.

The latch does not act as a ground, there is a different ground.
Yes the wiring to the module, orange being power can be an issue, corrosion or breaks in the wiring causing this.

Customer: replied 3 months ago.
Which plug going to module would be data wires power goes to the module the back latch moves when plunging and unplugging first plug
Customer: replied 3 months ago.
I disconnected both grounds and fobs worked for a while then stopped working
Expert:  Gm Tech (Cam) replied 3 months ago.

Its the 8 pin black connector, small light blue wire.