How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, GM Technician
Category: GMC
Satisfied Customers: 742
Experience:  Senior Technician
84449473
Type Your GMC Question Here...
Gary is online now
A new question is answered every 9 seconds

GMC Yukon 2007 6.2 motor code u0101

Customer Question

GMC Yukon 2007 6.2 motor code u0101
Submitted: 1 month ago.
Category: GMC
Expert:  Gary replied 1 month ago.

Hi Donnie,

If you have a no crank condition, then this may help:

http://www.autocodes.com/u0101_gmc.html

Gary

Customer: replied 1 month ago.
It's more than that there are other codes and problems that start out with the tcm I did look at that page previous to contacting you here is what is going on the transmission is in limp mode I cannot find the connectors that they are talking about in that link to see if it is workingThe door locks are going on and off I checked all the fuses and some fuses are reading no power but the things the fuses or for are still working I have a list of all the fuses that don't show no power if you need to give them to you
Expert:  Gary replied 1 month ago.

Ok, you need to list all of the codes from each module, ie ECM U0101, BCM U0100 etc.

This circuit may help.

Gary

Expert:  Gary replied 1 month ago.

Hi Donnie,

This is sounding like a BCM or power/ground issue.

Gary

Customer: replied 1 month ago.
Since this started I cannot get the codes The connector has no power now also would it be easier to contact you on the phone to explain everything
Customer: replied 1 month ago.
Or what is the best way to find the power ground issue
Expert:  Gary replied 1 month ago.

I'm in Australia Donnie.

I will look up some more info and come back to you shortly.

Gary

Customer: replied 1 month ago.
Do you have any idea why some fuses have no power but are still good here are a list of the fuses
3 no power do not have a trailer to find out if it is working4 no power do notknow if is working7 front washers no power but they are working10 trailer back up lamp no power have no trailer to check them15 no power vehicle back up lamps not working17 ac no power but is working22 no power rear washer but are working28 no power born but is working29 no power pastor side highbeam but is working31 no power driver side highbeam but working44 no power lift gate release but is workingthat is for under hood in the fuse boxThese fuses are driver side door panelunlocked 2 unlock 1 lock 1 lock 2 show no power but are working
Expert:  Gary replied 1 month ago.

Hi Donnie,

Can you check with a voltmeter what voltage you have at the battery, and the ALDL diagnostic connector pins 16 and 5?

http://pinoutguide.com/CarElectronics/gm_car_obd_ii_pinout.shtml

I would be more concerned with no ALDL communication than your list above.

Example of things working but no power doesn't make sense.

Mode than likely you have low volts to PIN 16.

Gary

Customer: replied 1 month ago.
12.18 add battery
Pin 16 11.67
Pin 5 00.01 with the key on not running
Expert:  Gary replied 1 month ago.

Ok, battery and ground at ALDL are ok.

Can you measure resistance across 6 and 14, key out vehicle asleep.

Should read 60 ohms.

Customer: replied 1 month ago.
Not trying to sound dumb but negative and positive one at 16 one at 14
Customer: replied 1 month ago.
6
Expert:  Gary replied 1 month ago.

Doesn't matter which way.

Across 6 and 14, should be 60 ohms.

Customer: replied 1 month ago.
How do I get it to read ohms
Expert:  Gary replied 1 month ago.

Your meter is on the 200 ohm scale, perfect for me.

The meter should read zero with the leads shorted, as a first test, which you should always do.

Now across 6 and 14 should read 60 ohms.

What do you get, 60, 120, or open, or short circuit?

Gary

Customer: replied 1 month ago.
It reads 61.0
Customer: replied 1 month ago.
Key off
Expert:  Gary replied 1 month ago.

Ok, the high speed bus is ok.

Have you tried another scan tool, or yours in another car?

Also, what accessories are fitted to the vehicle?

Gary

Customer: replied 1 month ago.
I have a pocket scanner that I use to go to the auction with that always worked and a new pocket scanner I bought but never used and try today and said the same thing let me go out to my other car and try my original pocket scanner
Expert:  Gary replied 1 month ago.

Ok.

Customer: replied 1 month ago.
It is reading zero codes
Customer: replied 1 month ago.
On my other vehicle
Customer: replied 1 month ago.
That is from the vehicle that we are talking about
Expert:  Gary replied 1 month ago.

Hi Donnie,

I would prefer a GM scan tool myself.

When was the vehicle last driven?

Gary

Customer: replied 1 month ago.
I know I would to preferred G MI was driving it on Sunday when it went into limp mode where only go 45 miles an hour max I think it is stuck in third gear did not drive or Monday but worked on it and move some wires connectors around the fuse box Driver side under hood went back to normal one started the engine used it on Tuesday to drive an hour from my house and an hour back and five minutes from the house it went back into limp mode Wednesday I had to go back to finish the job drove it in limp mode on the back streets for hour and 15 minutes each way
Customer: replied 1 month ago.
If needed I can try a better scanner toll tomorrow
Customer: replied 1 month ago.
Its 1:30 am esttime going to bed let me know if you have any suggestions I can work on tomorrow when I get up and maybe contact you or you can follow up with me when you get time
Expert:  Gary replied 1 month ago.

Ok, I'll let you know about anything else that might help.

Good night for now.

Gary

Customer: replied 1 month ago.
Thanks
Expert:  Gary replied 1 month ago.

Hi Donnie,

I think it would be best to have a vehicle wide scan done with a GM scan tool.

Module presence check is the first thing to do.

If still no communication with a GM scan tool, then the accessory wake up may be missing.

You say it went to limp home mode, which would be 3rd gear, and limited engine speed etc.

I feel I may not be able to help you with this much further.

I can open the question to other techs if you wish, but I recommend that a dealer has all the tools to diagnose this problem, of which I am remote, so difficult for me.

I hope my advice has been of assistance to you.

Kind regards

Gary

Expert:  Gary replied 26 days ago.

Hi Donnie,

Do you need any further help?

I hope my advice has been of assistance to you.

Kind regards

Gary

Related GMC Questions