How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), GMC Technician
Category: GMC
Satisfied Customers: 43918
Experience:  16 years of experience
Type Your GMC Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

GMC Envoy: accidently crossed ground and left turn signal wires

Customer Question

accidently crossed ground and left turn signal wires on light plug for trailer..then lost power to ignition and all things that run off ignition. Only have taillights and stoplights. Have 2002 GMC Envoy
Submitted: 6 months ago.
Category: GMC
Expert:  Gary replied 6 months ago.
in the under hood fuse box are ALL the big fuses good testing them in place through the little openings in the tops of them ?
Customer: replied 6 months ago.
Just checked and they are OK
Expert:  Gary replied 6 months ago.
ok can you see at the inside rear fuse box under the drivers center seat if the bog power wire bolted to that box shows 12 volts at the stud its bolted too ?
Customer: replied 6 months ago.
Yes it shows 12 V
Expert:  Gary replied 6 months ago.
ok can you see if any of the fuses in the rear fuse box are blown ?
Customer: replied 6 months ago. seems where the main wire comes in to fuse box has power but when you check the fuses they all look good. Did take tester and checked a few of the fuse cavities and couldn't get power.
Expert:  Chris (aka-Moose) replied 6 months ago.
Welcome, I'm Chris (aka Moose). I normally log in after 3 pm central. Please make sure to let me know exactly what is needed from me so I can provide EXCELLENT 5 STAR service. Different tech here, would you like me to try?
Customer: replied 6 months ago.
was surprised messages wasn't forwarded to you. During the waiting, I tried the battery again and it was down! Put 50amp charger for approx. 45 min then 12 amp to finish charge. Tried ignition and it started! Hooked trailer up and everything seems ok now. Still can't believe that by crossing the wires would have killed the battery.
Expert:  Chris (aka-Moose) replied 6 months ago.
Thats good news, glad you got it resolved.