How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gm Tech (Cam) Your Own Question
Gm Tech (Cam)
Gm Tech (Cam), GMC Mechanic
Category: GMC
Satisfied Customers: 1667
Experience:  GM Grand Master Technician 2007. 14 year experience.
10949255
Type Your GMC Question Here...
Gm Tech (Cam) is online now
A new question is answered every 9 seconds

Have a 2.2l sonoma blowing black smoke and idling rough have

Customer Question

Have a 2.2l sonoma blowing black smoke and idling rough have replaced injectors pressure regulator and plugs wires and map sensor was the only code it had thrown
Submitted: 9 months ago.
Category: GMC
Customer: replied 9 months ago.
Motor also shakes like it's missing while rpms raise have checked for all vacuum leaks all vacuum lines have been replaced. Runs very rough but will not stall and is very had starting have to hold pedal to the floor
Expert:  Reggie Whiddon replied 9 months ago.

So the only code it's throwing is for map sensor? What are your fuel trims. Long and short? Whst about coolant temp and intake air temp, and lastly have you Checked the timing chain I've had several where the tensioner broke it jumped a few teeth and ran like crap

Customer: replied 9 months ago.
only code is for map may have new ones by now have a decent scanner arriving tomorrow. I do not know about fuel trims as I do not have a diagnostic computer capable at this time coolant temp normal as far as intake air temp have not checked that nor the timing chain it was going to be my next step along with testing fuel system for leak down as far as timing chain removing the cover would i be able to tell if it have jumped time? Makes since being that it seems to miss worse when rmps go up and being that the truck has 140k probably due for one anyway
Expert:  Reggie Whiddon replied 9 months ago.

Yes when you pull cover off you can see therr are dots on thr gears turn crank over and see if they line up if they don't ,your out of time. And yes by mileage your due. Let me know whst you find with timing chain

Customer: replied 9 months ago.
Just about to check timing chain got my scanner that's OK for a novice shows alot more then some air intake temp was 59 degrees F .. and I was able to screen shot a pic of the timing as I was watching it it was bouncing all over the place for 6.0 to 22.0 I'm a diesel technician so alot of this I'm learning as I go ganna go get dirty hope the screen shot says something that catches your eye . Thanks
Customer: replied 9 months ago.
Looked at timing motors still in time all three marks lineup tensioners definitely was damaged on one of the guides got new timing kit and tensioner to install today
Customer: replied 9 months ago.
Motor was in time but the timing chain was loose compared to the new one I just installed will be putting back together tomorrow have rotated motor 2 complete cycles and timing marks still line up perfentry will let you know what it does after this
Expert:  Reggie Whiddon replied 9 months ago.

Sir you got it, good job

Expert:  Reggie Whiddon replied 9 months ago.

Good morning get that timing chain in

Customer: replied 9 months ago.
just started it still same issue needed to be done but not the problem at hand
Expert:  Reggie Whiddon replied 9 months ago.

okay lets back up tell me is it the exact same?

Customer: replied 9 months ago.
sir, rough idle black smoke out exhaust idles like it missing like it has a huge cam in it lobes almost what a vacuum leak would do bit there's no vacuum leaks
Expert:  Reggie Whiddon replied 9 months ago.

okay another thing comes to mind I had quite a few of these the pcm would go bad and hold the injectors open, if you removed all 4 injector connectors and ohm each injector and then put a noid light in each connector with key on and see if light is lit constantly with iey on

Customer: replied 9 months ago.
Ok will do Imy thinking it's something to do with the pcm I would understand if 1 or so cylinders were wet If i accidently busted a seal installing the new injectors but all the cylinders were wet so I don't think I busted all of them they went in perfectly
Customer: replied 9 months ago.
I have access to lights to test injectors so if each individual one stays on with the key on that's the sign that the PCM is bad also my set only has one per make so I test each individual one with ignition in on position
Expert:  Reggie Whiddon replied 9 months ago.

Yes Sir THAT Is Right

Expert:  Reggie Whiddon replied 9 months ago.

Hopefully you Wil find your problem there

Customer: replied 9 months ago.
Injector ohms are within range and noid test injectors seem to be firing as should each one had same strong constant flash as should
Expert:  Reggie Whiddon replied 9 months ago.

And none were on constant, okay since you have no codes i would try unplugging one sensor at a time to see if any has an effect. I am going to look into this be right back

Customer: replied 9 months ago.
Have gone through that' when issue 1st came all sensors made no difference besides map sensor which had been tested and replaced
Expert:  Reggie Whiddon replied 9 months ago.

try unplugging and running what effect

Customer: replied 9 months ago.
Effect was about every couple rotations it would fire and immediately die
Customer: replied 9 months ago.
Is there a way you know of to jump the coolant temp sensor it's the 3 prong i read it can give hard starts and long cranking? Just a shot in the dark
Customer: replied 9 months ago.
Since it sounds like it's missing what are the chances of a coil or coils going bad and not throwing a code being that the cps sensor feeds them
Customer: replied 9 months ago.
Now i.have a crank no start with still a map sensor code but this sensor is good I believe it's flooding so bad it won't start now
Expert:  Reggie Whiddon replied 9 months ago.

GMorning sorry had grandkids didn't get to get on here let me get u some info hold on

Expert:  Reggie Whiddon replied 9 months ago.

on the coolant temp unplugging it would go cold jumping it all the way hot,

Expert:  Reggie Whiddon replied 9 months ago.

Could you send me some pics of wnat your data is

Expert:  Reggie Whiddon replied 9 months ago.

coolant temp, map sensor key on engine off map sensor crank or start, rpm, short and long term fuel trims, intake air temp, tps,

Expert:  Reggie Whiddon replied 9 months ago.

Is your exhaust possibly restricted

Expert:  Reggie Whiddon replied 9 months ago.

Hello sir are you still working on this,