How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gm Tech (Cam) Your Own Question
Gm Tech (Cam)
Gm Tech (Cam), GMC Mechanic
Category: GMC
Satisfied Customers: 1667
Experience:  GM Grand Master Technician 2007. 14 year experience.
10949255
Type Your GMC Question Here...
Gm Tech (Cam) is online now
A new question is answered every 9 seconds

Both key fobs stopped working on my 06 envoy. Rear wiper

Customer Question

Both key fobs stopped working on my 06 envoy. Rear wiper does not work and initially both stopped working. I started simply and replaced batteries. One started working and rhe orher did not. Eventually both stopped again. Yried on line reactivation but no luck. Help
Submitted: 11 months ago.
Category: GMC
Expert:  Gm Tech (Cam) replied 11 months ago.

Hi there, I am Cam.
Sorry to hear about this issue. Did both the fobs and the rear wiper fail at the same time?

Does the rear hatch open normally and lock/unlock properly?

Customer: replied 11 months ago.
The rear hatch will not lock although initially the rear hatch was locked and would not open. Later I discovered it unlocked. I am not sure if rear wiper stopped at same time. Sorry. Just discovered it
Expert:  Gm Tech (Cam) replied 11 months ago.

Its not the hatch, but the overall operation of the keyless entry I am am thinking about.

Customer: replied 11 months ago.
I was replying to your question. I was able to trip alarm so alarm works and will activate. Fobs still failing. Alarm inducator on dash occasionally flashes when manually licking doors. Auto door locks operate but not fobs
Customer: replied 11 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Gm Tech (Cam) replied 11 months ago.

I believe your issue is related to the wiring that runs to the rear hatch. What I need you to do is open the hatch and inspect the wiring that runs through the rubber boot to the hatch and inspect for damaged or broken wires. I suspect you will find one or more cracked.

Customer: replied 11 months ago.
I will check tomorrow morning. Please be advised that I have used two on line processes for the fobs and while everything in the sequence works, including the automatic unlocking and locking but it did not appear that the car exited the program mode, thus the fobs did not activate. I will check wiring and harness tomorrow
Expert:  Gm Tech (Cam) replied 11 months ago.

Ok.

Related GMC Questions