How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dave Nova Your Own Question
Dave Nova
Dave Nova, GMC Technician
Category: GMC
Satisfied Customers: 19450
Experience:  ASE Master Certification. GM World Class Certification
11042942
Type Your GMC Question Here...
Dave Nova is online now
A new question is answered every 9 seconds

I have a 2002 GMC sierra 1500 z71 5.3l engine 4l60e

Customer Question

I have a 2002 GMC sierra 1500 z71 5.3l engine 4l60e transmission my problem just started my speedometer stop working and the check engine abs and parking brake light come on it won't shift past second gear
Submitted: 1 year ago.
Category: GMC
Expert:  Dave Nova replied 1 year ago.

Did you pull speed sensors from transfer case?

Customer: replied 1 year ago.
I have all three out
Customer: replied 1 year ago.
I don't know how to test are know which is bad and is that what can cause this issue
Customer: replied 1 year ago.
I hope this is a real site with true info and true certified mechanics after paying money on here
Expert:  Dave Nova replied 1 year ago.

The site is definitely real. Do you have access to an ohmmeter?

Customer: replied 1 year ago.
Not at the moment but I will tomorrow this site said $5 down and the $23 after satisfied with answer my account was charged $28
Customer: replied 1 year ago.
You can tell what ohm to put meter on and what it should read
Customer: replied 1 year ago.
We don't even know if this is the problem and I'm charged full price that's crazy
Expert:  Dave Nova replied 1 year ago.

Connect meter leads across each sensor (one meter lead to each terminal on the sensor) Should read in the range of(###) ###-####ohms. Another test you can do is to swap around the position of the two rearward sensors to see if the speedo starts working again.

The money you paid stays in your account. None of it is paid to the expert until you are satisfied with the service.

Customer: replied 1 year ago.
There's 3 back there just alike do these cause the problem with shifting and how do they cause it to cut the speedometer to not working all gauges in cluster work except the mph how fast you going one
Expert:  Dave Nova replied 1 year ago.

When you lose speed signal, the computer will not shift the transmission. Also no speed signal to instrument cluster for speedometer. No speed signal to ABS computer so abs and brake warning lights will be on. Also cruise control will be inoperative. Most common problem is a failed sensor. Since you have them all out and have no way of knowing which one was in the position of vehicle speed sensor, best to take ohmmeter reading and replace the one that reads bad.

Customer: replied 1 year ago.
OK so all 3 do the same thing cause I put a new one in place of the very back right side on transfer case thinking it run the speedometer no change so I took it back cause I figured it was money wasted so could any one of them cause the problem do they work together what do they all do
Expert:  Dave Nova replied 1 year ago.

One is vehicle speed. One is output speed for transfer case control module, one is transfer case input speed.

Left (drivers side) rear should be the one in question.

Customer: replied 1 year ago.
Ok so the 3 wires that power them is there a certain order they plug cause I lost memory on them also could you send me wire colors to which sensor if so I'm bout to try to test them if I can find my meter
Customer: replied 1 year ago.
What to set meter on for test
Expert:  Dave Nova replied 1 year ago.

Set on Ohms. Meter should automatically adjust scale.

Customer: replied 1 year ago.
I can't find meter I'll buy one tomorrow but on wiring harness to transfer case is there certain color plugs to each sensor cause they will reach around all over I figured they would stay inline with lengths
Customer: replied 1 year ago.
You sure the left driver side is speed sensor the one that should be causing my problem and that's lookin at tail shaft of transfer case where rear end driveshaft goes its the one to left by its self the top one and passenger side one are the other 2 for transfer case info on wiring do you know the plugs to hook wires back correctly
Customer: replied 1 year ago.
On YouTube 1aauto.com video he said the passenger side is the speed sensor that on right side transfer case
Customer: replied 1 year ago.
I just hope this fixes my problem tomorrow have you runninto this problem on this style vehicle before
Expert:  Dave Nova replied 1 year ago.

Good morning. I have seen this problem numerous times before. Check the picture attached. The main sensor for speedometer and computer operation for shifting, abs, etc. is highlighted. Wire colors for this sensor are Purple/White and Light Green/Black.

Customer: replied 1 year ago.
All the speed sensors on meter are reading around 1,467 ohms
Customer: replied 1 year ago.
You say it should read 1300 to 1800 so these are reading good I'm lost again
Expert:  Dave Nova replied 1 year ago.

Try reinstalling the sensors. Install the new sensor to the drivers side rear location and test drive to see if the problem is still present. Let me know.

Customer: replied 1 year ago.
I don't have the new sensor I had took it back all 3 my old ones reading that I'm headed to get some new ones this has me mixed up could it been the wiring plugged in wrong spots knowing the plugs are all the same
Customer: replied 1 year ago.
When I replace them all new and if it don't fix what's next cause its over a $100 for 3 sensors
Customer: replied 1 year ago.
This did not fix problem anything else control it
Expert:  Dave Nova replied 1 year ago.

Follow wiring harness up towards rear of transmission. Check connector there to make sure it is fully plugged in.

Customer: replied 1 year ago.
Is there a way to check plug tips to see if they getting fire for where they plug into sensors
Expert:  Dave Nova replied 1 year ago.

You can take ohmmeter reading at the PCM connector. If you want to to this, let me know and I will get you the connector diagram of the PCM.

Customer: replied 1 year ago.
I got it it was the wire on top the trans that comes off trans main brain plug I had its plug and speed sensor wire in wrong spots I swapped them truck is back to normal no lights on speed ometer back good thanks for your help in keeping me on the wire track
Customer: replied 1 year ago.
I rate you 100 im satisfied what do I do now on here
Expert:  Dave Nova replied 1 year ago.

If you are satisfied with my service then we are done. Certainly let me know if you need any assistance in the future. Glad I could help you.

Dave