How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, ASE Certified Technician
Category: GMC
Satisfied Customers: 15711
Experience:  GCM master tech over 25 years
19513769
Type Your GMC Question Here...
Gary is online now
A new question is answered every 9 seconds

99 Yukon Denali 5.7 turns on runs to 15 minutes. Then turns

Customer Question

99 Yukon Denali 5.7 turns on runs for 2 to 15 minutes. Then turns off. Dose not sputter light stay on. Just turns off. Try to re start will not. I need to turn the key all the way off then crank it and it will run for 2 to 15 then turn off. Fuel pressure stays at 55 psi. Intake vacume pressure at 20 psi. Replaced distributor spark plugs cap and rotor and one fuel injector after it started doing this because it was throwing a p0300 fixed that but still turns off. Security light dose not blink and dose turn off.
Submitted: 1 year ago.
Category: GMC
Expert:  Gary replied 1 year ago.

when it will shut off and not restart will it somewhat run on starting fluid ?

Customer: replied 1 year ago.
I'll try ut right now
Expert:  Gary replied 1 year ago.

ok

Customer: replied 1 year ago.
I wanted to try and put a noid light in the spinder clip see if it was sending a signal
Expert:  Gary replied 1 year ago.

you can do that also

but we need to know if it will run on starting fluid or carb cleaner as its being sprayed into the engine

Customer: replied 1 year ago.
It will run with the fluid
Expert:  Gary replied 1 year ago.

ok unplug the big fuel injector connector and with the key ON see if 8 terminals in the connector you unplugged show 12 volts

or use a noid light

or connect a test light with the test light clip to a good 12 volts do the other 8 blink your test light bulb when cranking it over ?

Customer: replied 1 year ago.
Turned it on let it run until it turned off tried to start. No start took the clip off all 8 flashing with non s light. Pluged back in ran then turned tested it again still getting signal. Tryed again all I did was unplug then plug it back and would start. Would start after unpluging it every time but turn off shortly after
Customer: replied 1 year ago.
Usly will have to wait 5 minutes before it will turn back on
Expert:  Gary replied 1 year ago.

so it always has 8 blinking and 8 showing 12 volts and it will run when adding fuel ?

key ON engine OFF what is the fuel pressure ? and will it hold somewhat ?

Customer: replied 1 year ago.
It shows all 8 blinking. And it will run when adding fuel. Fuel psi us at 55 and holds steady after turning the key off.
Expert:  Gary replied 1 year ago.

is the fuel filter new ?

the problem we have is if you add fuel and it runs we know it is a fuel problem

the fuel pump spec is 60 - 66 PSI key ON engine OFF

since you have a good injector pulse this issue gets narrowed down to dirty fuel injectors or low fuel pressure

if you change the fuel filter will the pressure come up ?

Customer: replied 1 year ago.
I'll change it now
Expert:  Gary replied 1 year ago.

see if the pressure comes up close to 60

if it does then does the problem go away or get alot better ?