How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, ASE Certified Technician
Category: GMC
Satisfied Customers: 15926
Experience:  GCM master tech over 25 years
19513769
Type Your GMC Question Here...
Gary is online now
A new question is answered every 9 seconds

We have a 02 GMC Sonoma with 4.3 engine that has had the Fuel

Customer Question

We have a 02 GMC Sonoma with 4.3 engine that has had the Fuel Pump replaced and Spider Injector Cluster Replaced. The vehicle still will only start when have carb cleaner sprayed into the throttle body.
Submitted: 1 year ago.
Category: GMC
Expert:  Gary replied 1 year ago.
I am sorry for the long waitcan you unplug the big connector on top of the fuel injector and there are 12 terminals in that connector you unplugged with the key ON do 6 show 12 volts ?if so then connect your test light to a confirmed good 12 volts at the battery and when cranking it over do the other 6 blink your test light bulb when cranking it over ?
Customer: replied 1 year ago.
Working on that test right now!
Expert:  Gary replied 1 year ago.
ok nu rushalso when you have the key on and are cranking it what is the security / theft light doing ?
Customer: replied 1 year ago.
We have a friend that works for our local chevy dealer and he had ruled out the theft system when he stopped over before we did the spider cluster, but he is on vacation now that we have installed the spider cluster
Expert:  Gary replied 1 year ago.
ok if your 100 % sure the theft system is NOT the issue then do that test with the test light and tell me if you missing the 6 showing 12 volts with the key on or the 6 are not blinking a ground
Customer: replied 1 year ago.
All 6 injector pulses were lighting with a noid light
Expert:  Gary replied 1 year ago.
key ON engine OFF what is the fuel pressure at the fuel test port drivers side rear of the engine near the distributor ?
Customer: replied 1 year ago.
60 psi
Expert:  Gary replied 1 year ago.
and this will run on starting fluid ? with 60 PSI of fuel pressure and 6 terminals showing 12 volts and 6 blinking when cranking it over ?
Customer: replied 1 year ago.
Yes, it will
Expert:  Gary replied 1 year ago.
6 where blinking a ground when cranking it over ?if so if you unplug the 2 wire engine coolant temp sensor will it start up ? if not plug that back in and unplug the TPS will it run ?
Expert:  Gary replied 1 year ago.
if it will not run we need to take a fuel sample in a glass jar and fill it up over 1/2 way and then let it sit for 10 minutes do you see any separation at all ?gas will float on top of waterif it has fuel pressure and a good pulse and will run on starting fluid and NO codes set and unplugging the ECT and TPS it will not run either the fuel in contaminated with water or something OR the injection spider is bad
Customer: replied 1 year ago.
We tried to unplug the 2 wire engine coolant temp senor and would not start and we plugged it back in and unplugged the TPS and did not run.
Expert:  Gary replied 1 year ago.
if it has fuel pressure and a good pulse and will run on starting fluid and NO codes set and unplugging the ECT and TPS it will not run either the fuel in contaminated with water or something OR the injection spider is badcheck the fuel like i said if its 100 % good then pull the upper intake and pop out the injectors out of the intake and when cranking it over do you see fuel pulse out of the injectors good ?
Expert:  Gary replied 1 year ago.
also please make sure the injectors are in the correct cylinders