How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, ASE Certified Technician
Category: GMC
Satisfied Customers: 16635
Experience:  GCM master tech over 25 years
19513769
Type Your GMC Question Here...
Gary is online now
A new question is answered every 9 seconds

GMC terrain: my 2012 gmc terrain shuts off sometimes when i

Customer Question

my 2012 gmc terrain shuts off sometimes when i let up on the gas pedal and sometimes shuts off when i start it up and put in gear
Submitted: 2 years ago.
Category: GMC
Expert:  Gary replied 2 years ago.
Welcome! My name is ***** ***** I will do my best to assist you with this problem.
I am sorry for the long wait
will it drive fine down the road when your foot is into the gas pedal and more so a stall with your foot off the gas pedal issue ?
are there any codes in the computer at all ?
what size engine is in this ?
Customer: replied 2 years ago.
it drives fine down the road when my foot is into the gas pedal and then stalls if i let up on the gas(sometimes). no codes on the computer at all. Engine type: 2.4L L4 DOHC 16V
Expert:  Gary replied 2 years ago.
Thank you for that information
most of these kind of issues with no codes being set are usually one of 2 simple things
the throttle body is dirty or the MAF is dirty
the best action to take is to pick up a can of carburetor cleaner and MAF spray cleaner
pull out the MAF in the air cleaner and clean it good with MAF spray cleaner then remove the hose on the throttle body on the engine from the air cleaner and clean out the throttle body with the carb cleaner making it spotless and make sure you do NOT pry open the throttle body butter fly
once both are cleaned re install everything and take it for a good ride
this should correct this issue you are having