How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), GMC Technician
Category: GMC
Satisfied Customers: 45082
Experience:  16 years of experience
2499435
Type Your GMC Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

GM yukon: 2007 Yukon 5.3.shows misfire on #3 and #8 cylinders.new

Customer Question

2007 Yukon 5.3.shows misfire on #3 and #8 cylinders.new plugs,wires,coils are good injectors are pulsing.runs rough at idle and low speeds.runs great at highway speeds.several warning codes.
service brakes soon
check traction stabilizer
tow buton on gear shift wont work ect...
wife driving home in rain and everything happened at once
170,000 miles
Submitted: 1 year ago.
Category: GMC
Expert:  Chris (aka-Moose) replied 1 year ago.
Hello, I'm Chris. Thanks for seeking us for help.
I am sorry for the delay in getting a response to you. Sometimes we get alot of customers and just can not keep up. Sometimes you just have to wait for the correct tech to login.
Do you even still need help. Sometimes customers seek help elsewhere or figure it out on their own before we get to each and everyone.
I am sure I can help a lot or a little at least something if you give me a chance and work with me. I am going to get an answer to you regardless if you reply or not sooner or later.
If your concern is urgent reply and let me know and if you have anything more you think will help me, to help you, let me know. I work on here normally 3pm-3am central.
Thanks Chris
Customer: replied 1 year ago.
yes.please respond
Expert:  Chris (aka-Moose) replied 1 year ago.
Hi
Can you check the compression on these cylinders and the surrounding ones. Do you have access to a lab scope to monitor the coil and injector command on these cylinders compared to others to see if the computer is not getting equivalent signal to each. Have you unplugged the computer to see if the connector has moisture in it?
You want a excellent 5 star answer & I would like to be rated the same for providing it. Consider I don't know your skill level & I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies. Try your best to respond with good detail so I can do the same. I normally log in at 3pm and work late. A rating is required. Your rating me, what I type. I am not an employee of this website, nor have control over the fees or the time it took to get a response. If you rate negative or not at all you still paid, but I get nothing. I want you pleased with me and my efforts, so let me know if your experience here has come up short.
Thanks Chris
Customer: replied 1 year ago.
we ran a compression check on the #3 cylinder.it shows 150pds.checked the injectors and they are pulsing.did not check ecm plug for moisture but with all of the warnings and the tow button not working on the gear shift is what im leaning towards plus it was raining like hell when this happened. I am not a certified tech. by no means but my father worked for a ford dealership in texas for 25 to 30 yrs as a mechanic and retired as service manager.so I do have I would say better than average knowledge.its at a dealership as we speak getting diagnosis.took to one before they say lifter but i'm having a hard time believing this.
Expert:  Chris (aka-Moose) replied 1 year ago.
Keep in touch if needed or if the return it unfixed.
Customer: replied 1 year ago.
really. that's it .I pay you money for your perfessional opinion and knowledge and the best you got is I don't know your skill level or can see hear or touch the car let me know if problem returns unfixed.good job chris or moose which fits with your answer.money well spent;
Expert:  Chris (aka-Moose) replied 1 year ago.
I mentioned things to check and you said the vehicle is at the dealership, so you are unable to do those tests. I do not see what we can do to figure this out when you do not have the vehicle. Did I misunderstand?
You have paid me nothing.
Customer: replied 1 year ago.
don't contact me anymore
Expert:  Chris (aka-Moose) replied 1 year ago.
Okay