How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: GMC
Satisfied Customers: 33415
Experience:  35 years in the Automotive repair business.
7276279
Type Your GMC Question Here...
Ron is online now
A new question is answered every 9 seconds

GM savana: I have a 1999 GMC savanna 1 ton van, 5.7 liter,

Customer Question

I have a 1999 GMC savanna 1 ton van, 5.7 liter, had problems with fuel, resolved that with new pump and relay, had other odd issues and replaced crank sensor and coil, tested ICM at autozone, no spark. Any ideas?
Submitted: 1 year ago.
Category: GMC
Customer: replied 1 year ago.
no spark from coil that is. tried new plug wire as well.I have 12 volt to the coil and get a pulse when checking the signal connection from the ICM
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Provide Diagrams, Manuals, or Instructions. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Ron replied 1 year ago.
Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
The problem you are describing with the lack of spark can be cause by any of the following,
Crankshaft Position (CKP) Sensor
Distributor Cap
Ignition Module
Ignition Rotor
In order to determine which has failed you are going to need to do some testing. I have enclosed the test steps in the link below, copy and paste the link to your browser to open and view them.
https://dl.dropboxusercontent.com/u/104923897/No%20spark%20May%2019.pdf
Customer: replied 1 year ago.
Thank you for your help. I have replaced the CKP, had the Ignition module tested and don't understand why the cap or rotor would have any bearing with no spark from the coil. I thought the cap and rotor were to pass the spark along to the plugs.
Expert:  Ron replied 1 year ago.
Its not uncommon for the test that Auto Zone runs on the ICM to be defective, are you 100% sure the ignition module is not defective? The cap and rotor should be fine if you are not getting fire from the coil.
Customer: replied 1 year ago.
How would I be able to confirm their test results ?
Expert:  Ron replied 1 year ago.
Run the test steps I have sent you in the link.
Customer: replied 1 year ago.
I have good ground, 11.7 volts on the pink wires, I tried my portable scope and didn't look good. Will try full size scope later. ( surprised I even have one or two?)
Expert:  Ron replied 1 year ago.
Okay let me know . Im here today.

Related GMC Questions