How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary, GMC Technician
Category: GM
Satisfied Customers: 15564
Experience:  15 years gm master tech/15 years ASE master tech
Type Your GM Question Here...
Gary is online now
A new question is answered every 9 seconds

Just had my xsmn rebuilt. Having trouble wiring the NSS. The

Customer Question

Just had my xsmn rebuilt. Having trouble wiring the NSS. The wires I have from the harness does not match any pin out diagram I can seem to find. The wires I do have are black, pink, LT grn, drk grn, and grey. Also my ground wire (black) has voltage now. It's a 4l60e from a 03 GMC Sierra. Help! Lol
Submitted: 5 months ago.
Category: GM
Expert:  Gary replied 5 months ago.
the NSS should have 2 connectors one has 7 cavity's but uses 6 wires the other has 4 terminals and 4 wiresboth are seen on the pictures i attachedas for the black being voltage it should be a ground if all the grounds are clean and tight just run a new good ground to that wireif you have any questions please ask as i do not get credit for my work until you rate me here at Justanswer
Customer: replied 5 months ago.
Those diagrams are what I have, but the diagram for the 7 pin connector does not match the color wires I do have like said, also running a chassis ground to the NSS should work?
Expert:  Gary replied 5 months ago.
total wires you should have 10 for the 2 connectorsdo you have 10 ?
Customer: replied 5 months ago.
I have ten, it's the 6 wires for the 7 pin connector i am having trouble with
Expert:  Gary replied 5 months ago.
but there should only be 1 grey and that grey goes to the other connector the 4 terminal one.....peeling back the tape on the wiring is the color faded on that grey wire where it could be a yellow one ?you have the 2 greens and the black and pink correct ?that leaves terminals E and G not matching correctly ?
Customer: replied 5 months ago.
Yea E and G are the ones not matching up and the 4 pin connector was not replaced. So all the wires running to the plug is how it was. And I did peel back the wire to verify it is grey
Expert:  Gary replied 5 months ago.
ok one of those 2 wires left should show 12 volts with the key being held to crank can you test for this ?
Customer: replied 5 months ago.
the grey does show voltage and I have tried wiring it to E and G. Also I just ran a ground wire from my negative batt terminal to the D on the NSS and no change.
Expert:  Gary replied 5 months ago.
does the pink show 12 volts ?and with it plugged in does the dark green show 12 volts at it ?
Customer: replied 5 months ago.
Expert:  Gary replied 5 months ago.
the starter will not engauge ?
Customer: replied 5 months ago.
No, and the dash, radio, running lights and brake lights stay on after I pull the keys out
Expert:  Gary replied 5 months ago.
lets see if any other experts have any ideashang on
Customer: replied 5 months ago.
Thanks, ***** ***** did not have any of these issues before. I just had the xsmn rebuilt because the 3-4 clutch pack went out. Not sure if that helps any