How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Newton Your Own Question
Jerry Newton
Jerry Newton, GMC Technician
Category: GM
Satisfied Customers: 4412
Experience:  ASE Master Technician, L1, Master GM Technician. Over 20 years of bumper to bumper GM experience.
25345654
Type Your GM Question Here...
Jerry Newton is online now
A new question is answered every 9 seconds

My mane is ***** ***** and im having a problem with my 95

Customer Question

hi my mane is ***** ***** and im having a problem with my 95 chevy blazer
JA: Thanks. Can you give me any more details about your issue?
Customer: it runs fine at idle and when barely pressing the pedal. but the more gas u give it it starts to bog down. ive tested fuel pressure and it 60 psi at key on and holds. when running it never dips below 52psi at wot. ive done a pressure test (vaccuum) and the converter isnt plugged.
JA: OK got it. Last thing — GM Mechanics generally expect a deposit of about $32 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 7 months ago.
Category: GM
Expert:  Jerry Newton replied 7 months ago.
What was the vacuum gauge doing when you tested it at WOT? I'm not convinced that using a vacuum gauge is entirely accurate, I use an exhaust backpressure gauge for this testing, and I would recommend the same for you.
Customer: replied 7 months ago.
my vacuum gauge has indicators and it would pull negative the quickly go back to the green 0
Customer: replied 7 months ago.
im really think its sensor related... seems to run better when its warm outside and its worse when its cold outside
Expert:  Jerry Newton replied 7 months ago.
It went back to the green under WOT? As in, it was swinging to the pressure side of the gauge?
Customer: replied 7 months ago.
let me run up and get my gauge so i can explain it better
Expert:  Jerry Newton replied 7 months ago.
OK.
Customer: replied 7 months ago.
at idle its rading about 48 in the green at wot its 0 then upon recovery it hits around 60 and comes back to 48 .
Customer: replied 7 months ago.
This is the gauge I'm using
Customer: replied 7 months ago.
or it idle its 19... wot 0 then 22 back to 19 when recovering depending on the scale you want to use
Expert:  Jerry Newton replied 7 months ago.
OK, that makes more sense. I don't know what the numbers represent, normally we'd be talking about inches of mercury when referring to a vacuum reading, and normal numbers on that scale would be 18-20" at idle, 0" at WOT, and on decel you would see it climb up over 20". Edit: Oh, I see your image now, you're reading in PSI on the outer scale, but the reading is actually on the inner scale. No matter, we're on the same page here. My experience is that this is not normally a "sensor" issue. If the coolant temp sensor was bad, for example, it would be hard to start, and it would run badly across the board. Same for MAP sensor, etc. There aren't any sensors that would only affect WOT performance. I'd gamble the money in my pocket that you actually DO have a converter issue, and it needs to be measured with a back pressure tester. You can probably borrow this tool for free at Autozone, Advance, etc. It attaches in place of the upstream oxygen sensor, you go out and drive it with the gauge attached, and on WOT, you shouldn't have more than 1-2 psi of backpressure. If you go WOT, the engine bogs down, and the back pressure gauge is off the scale, your exhaust is plugged up. I have also seen fuel pumps that maintain pressure, but don't deliver volume. It doesn't make any sense, but I've been in exactly this position before, trusting my fuel pressure gauge and believing that there was sufficient fuel, but when it was all said and done, a new fuel pump fixed that vehicle. This issue is either going to be fuel delivery or restricted exhaust, based on the number of these issues I've seen over the years. I can't think of one sensor that would do this to an engine, and I've never seen this issue caused by anything besides exhaust or fuel delivery.
Customer: replied 7 months ago.
ive driven the truck with the fuel pressure gauge sicking out the hood and it never dropped below 52 and actually increases when you give it gas... seems to have plenty of exhaust coming out of the pipe... guess i will have to try and get the back pressure tester. it seems to pop in the intake when is bogging if u hold it in that range
Customer: replied 7 months ago.
if it doesnt have more than that what would u do next?
Expert:  Jerry Newton replied 7 months ago.
That sounds just like a plugged exhaust. We can't rely on that vacuum gauge reading to tell us whether the exhaust pipe is plugged up. I would source a back pressure gauge and check that the right way, before straying too far away from that. This is dependent on "feel". If it's ignition secondary that's not keeping up, due to a weak coil.... I mean, those sorts of things are possibilities, but just not likely to give you this problem and no other symptom to go with it.

Related GM Questions