How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, GMC Technician
Category: GM
Satisfied Customers: 24668
Experience:  14 years GM dealership technician and training.
14928985
Type Your GM Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 1996 silverado with a 6.5 diesel. I have a crank/no

Customer Question

I have a 1996 silverado with a 6.5 diesel. I have a crank/no start and my code reader is saying a lot p1656 wastegate solenoid control circuit, p0380 glow plug/heater circuit, p1653 fuel level output control circuit and p1656 evap purge solenoid control circuit. Do you think my pdm is bad or do I have problems with each one of those circuits?
JA: Thanks. Can you give me any more details about your issue?
Customer: It just quit running and it's not getting any fuel and the glow plugs have no power.
JA: OK got it. Last thing — GM Mechanics generally expect a deposit of about $32 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 8 months ago.
Category: GM
Expert:  Pete replied 8 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

The first thing to check here is to make sure all fuses are o.k. in all fuse panels.If any fuses are found to be blown at all the affected fuses will need replaced.If this has already been done and found to be o.k. let me know so we can continue.

Thanks Pete

Customer: replied 8 months ago.
I have checked all fuses and they are good
Expert:  Pete replied 8 months ago.

Can you tell me if the 8th digit of your VIN is a P or an S?

Customer: replied 8 months ago.
The eighth digit is an S
Expert:  Pete replied 8 months ago.

O.k.,double check that ENG 1 fuse is good and has power with key on.If this is o.k. check the Glow Plug fuse as well for power with key on.If both are o.k. there is a red wire that leads from the under hood fuse panel to the glow plug relay that has a blue fusible link wire tied into this red wire.Check and see if this fusible link wire is burned or broken or if when tugged on breaks easily.If it is then it needs replaced.

If these are o.k. or if you have no power on these fuses with the key on let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 8 months ago.
Ok I'll check those things and get back to you.
Expert:  Pete replied 8 months ago.

Sounds good.Let me know.

Customer: replied 8 months ago.
Ok so I got the glow plugs working again. I went through the fuses again and found the eng 1 fuze was blown. Now I'm back the first problem, there is no fuel at the injectors. I replaced all the injectors about a year and a half ago and the injection pump a few months after that. Four days ago I replaced the inline fuel pump, it is getting power it kicks on and runs for about 30 seconds or so. And all the fuzes are good I just checked again.
Expert:  Pete replied 8 months ago.

Are you getting any fuel from the in line fuel pump at all?

Customer: replied 8 months ago.
Not sure, I put a pressure gauge on it before I put the new one on and got no pressure but I could push the valve on the gauge and a little fuel came out, not sure if it was from the pump or the motor.
Expert:  Pete replied 8 months ago.

If you can I would check with a hose connected to the small inline pump on the frame rail,crank over the engine or turn on the key and see if fuel pumps out of the small inline pump outlet.If you can do this and let me know this will help.

Thanks Pete

Customer: replied 8 months ago.
I put a hose on the pump and it pumps pretty good
Customer: replied 8 months ago.
I pulled my whole fuel filter kit and the wires coming out of the bottom were bare where they go into the unit. Could that be the culprit?
Expert:  Pete replied 8 months ago.

I apologize for the delay as I had an emergency yesterday.

If you have bare shorted wires this can cause an issue like this here in some cases.I would repair the wiring and see if this resolves the fault and let me know.

Let me know if you need anything else and feel free to rate my help here.

Thanks Pete

Customer: replied 8 months ago.
I'm still not getting fuel out of the injection pump I'm going to check the fuel shut off solenoid. Is there a to test it or bypass it to see if I can get it to start.
Expert:  Pete replied 8 months ago.

If you clear out the codes which codes come back again now that the glow plugs are working?

Customer: replied 8 months ago.
The only code that comes back on P1656 wastegate solenoid control circuit.
Expert:  Pete replied 8 months ago.

Do you know how to read wiring diagrams and diagnostic procedures?

Customer: replied 8 months ago.
I can read them a little. I was wrong about the codes I also have the code P1218 injection pump calibration circuit
Expert:  Pete replied 8 months ago.

O.k.,the second code you just posted here makes sense and can lead to the injection pump at fault needing replaced which is very common.It is a short diagnostic for the code set.

Check and make sure the fuel solenoid driver connection and wiring is all o.k. and connected.If this is o.k. then the fuel injection pump needs replaced.Thats about it for this code here and with what you have going on here I suspect the injection pump at fault needing replaced.

Thanks Pete